Bug 118442 - Hard coded dependancy on XFree86-libs should not be present
Hard coded dependancy on XFree86-libs should not be present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks: xorgdeps
  Show dependency treegraph
 
Reported: 2004-03-16 14:33 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 00:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-03-16 14:33:00 EST
There are hard coded dependancies on some XFree86 subpackages
whi need to be fixed before xorg-x11 can be enabled in the
development tree.

The following is found in the spec file:
    BuildPrereq: Mesa-devel tk tix gcc-c++ XFree86-libs glibc-devel

Nothing should ever have a Requires, BuildRequires, or BuildPrereq
on the XFree86-libs subpackage, because those are runtime libraries,
and not development libraries.  If python, or something in the
python package needs to link to an X library, then the dependancy
should be on XFree86-devel, not XFree86-libs.

I found the changelog for this:

* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
2.2.2-3.*
- Merged patch from Karsten Hopp <karsten@redhat.de> from
2.2.1-17hammer to
  use %%{_libdir}
- Added XFree86-libs as BuildRequires (because of tkinter)


Not sure what tkinter needs XFree86-libs for, but that's almost
certainly an incorrect BuildRequires.  XFree86-libs package is
going to be removed from the distribution shortly, so this needs
to be changed to XFree86-devel if it is a dependancy needed for
development headers or developmental X11 shared library symlinks.

I can make the change if you like, as this is somewhat under
a time constraint, to get this fixed before the freeze tomorrow.

Thanks in advance.
Comment 1 Mihai Ibanescu 2004-03-16 17:11:43 EST
Fixed in 2.3.3-3
Comment 2 Mike A. Harris 2004-03-17 00:48:05 EST
Confirmed to be fixed:

$ rpm -qp --requires
/mnt/redhat/beehive/comps/dist/fc2/python/2.3.3-3/*/*.rpm |grep XFree86
XFree86-devel

Thanks for the quick update!

Note You need to log in before you can comment on or make changes to this bug.