Bug 118444 - ldap map lookup broken
Summary: ldap map lookup broken
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-16 19:35 UTC by Bill Nottingham
Modified: 2014-03-17 02:43 UTC (History)
3 users (show)

Fixed In Version: 4.1.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 21:10:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autofs config file (273 bytes, text/plain)
2004-03-16 19:36 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2004-03-16 19:35:22 UTC
Given the attached auto.master, startup fails with:

lookup(ldap): query failed for (&(objectcalss=nisObject))
lookup(ldap): query failed for (&(objectclass=automount))
failed to load map, exiting
failed to remove dir ^PP: No such file or directory.

The failed to remove directory error looks pretty bogus too.

Comment 1 Bill Nottingham 2004-03-16 19:36:10 UTC
Created attachment 98578 [details]
autofs config file

Comment 2 Jeff Moyer 2004-03-18 16:32:51 UTC
The ldap path initialization code changed between versions 3 and 4.  I
ported forward the version 3 way of parsing the ldap server name and
base DN.  This fix will appear in fc2t2.

-Jeff

Comment 3 Bill Nottingham 2004-03-18 16:38:25 UTC
Now, with a wildcard map, if I try to mount
/home/<some-user-whose-homedir-isn't-in-autofs>, it mounts the last
one in the entry.

Comment 4 Jeff Moyer 2004-03-18 16:50:51 UTC
Bill, could you provide a little more information?  When you say you
try to mount, do you issue the mount command by hand?  Do you try to
cd to a directory that doesn't exist?  And when you say it mounts the
last one in the entry, what precisely do you mean?  Exact steps to
reproduce the problem would be helpful.

Thanks,
Jeff

Comment 5 Stephen Tweedie 2004-03-18 17:20:01 UTC
I'm seeing exactly the same symptoms as Bill, using a NIS autofs map.
 "ls /home/foo" where foo is caught by the wildcard results in a
directory-not-found, and the logs show autofs was trying to mount the
last entry listed in "ypcat auto.home" (which happens to be
unreachable at present, hence the mount fails.)

Comment 6 Stephen Tweedie 2004-03-19 11:39:42 UTC
Appears fixed in autofs-4.1.1-1, at least for my NIS case.


Comment 7 Jeff Moyer 2004-03-19 19:51:40 UTC
autofs-4.1.1 fixed the wildcard issues.  It broke ldap, though.  I
fixed a bug dealing with too short timeouts, and all seems well.  I've
tested the nis case and the ldap case.  Both work for me in
autofs-4.1.1-3, which I built into fc2-HEAD.

-Jeff

Comment 8 Bill Nottingham 2004-03-19 21:10:56 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.