Bug 1184445 - Cannot mass disable VM Console Option "Map control-alt-del shortcut to ctrl+alt+end"
Summary: Cannot mass disable VM Console Option "Map control-alt-del shortcut to ctrl+a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: jniederm
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-21 12:32 UTC by Amador Pahim
Modified: 2019-04-28 09:38 UTC (History)
11 users (show)

Fixed In Version: 3.6.0-11
Doc Type: Enhancement
Doc Text:
Previously, users could remap the Ctrl+Alt+Del shortcut to Ctrl+Alt+End using the Console Options dialog in the Administration or the User Portal. With this enhancement, users can now use the engine-config utility with the 'RemapCtrlAltDelDefault' option to remap the shortcut keys. This global value can still be optionally overridden for each virtual machine using the Console Options dialog.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:54:50 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 39070 master MERGED backend: Add RemapCtrlAltDelDefault to config Never
oVirt gerrit 39071 master MERGED frontend: Load default value for "Remap Ctrl-Alt-Delete" Never
oVirt gerrit 39072 master MERGED tools: Allow setting RemapCtrlAltDelDefault boolean Never
oVirt gerrit 45103 master MERGED core, webadmin: Fix of overriding CtrlAltEnd ConfigValue by frontend Never
oVirt gerrit 45243 ovirt-engine-3.6 MERGED core, webadmin: Fix of overriding CtrlAltEnd ConfigValue by frontend Never

Description Amador Pahim 2015-01-21 12:32:29 UTC
Description of problem:

New "Map control-alt-del shortcut to ctrl+alt+end" is causing 2 issues:

1) users are used to use standard ctrl+alt+del so they complain this is suddenly not working anymore

2) users with igel.de thinclients run an old version of spice plugin from 2011 as vendor did not release a firmware with functional an recent spice plugin. on these clients users can't log in at all as they get the following error from userportal as long as ctrl+alt+del is mapped:

internal error: (code 1032)

For large deployments, we are not able to mass disable this option since it's not controlled over API or database.


Version-Release number of selected component (if applicable):

rhevm-3.4.4-2.2.el6ev.noarch


Expected results:

Please provide a way to mass disable/enable the console option "Map control-alt-del shortcut to ctrl+alt+end".

Comment 1 Yaniv Lavi 2015-01-22 12:42:41 UTC
Will not make it to 3.5. re-targeting to 3.6 for consideration.

Comment 2 Michal Skrivanek 2015-02-10 10:55:31 UTC
will create a global VdcOption config with a default

Comment 5 Michal Skrivanek 2015-07-23 12:43:12 UTC
there is a global setting which can be used.

Comment 6 jniederm 2015-08-06 17:38:02 UTC
I doesn't seem to work well. It looks like only global configuration is reflected in produced vv file.

Comment 7 Ilanit Stein 2015-10-07 13:35:17 UTC
Tested on rhevm 3.6.0-15.

For RemapCtrlAltDelDefault set to false (and ovirt-engine service restart),
For new/existing VM, with SPICE console, the console options still have the 
"Map control-alt-del shortcut to ctrl+alt+end" check box marked with "V"

Comment 8 jniederm 2015-10-08 12:36:08 UTC
Tested on current 3.6 branch, commit cf4f923
It seems to work as expected.

If I understand it correctly there is no problem with Console Options dialog setting correspondence to real behavior but rather that the global engine option doesn't match the Console Options. Maybe following description can make intended behavior clear:

There are two levels of remapping control:
1. The global engine option
2. Custom setting per vm stored in browser local storage that overrides the global option.
So if the setting for particular vm was never stored in browser (by confirming Console Options dialog) then global setting is respected. Otherwise it follows per browser and vm custom setting.

Can we now consider it working?

Comment 9 Ilanit Stein 2015-10-14 15:09:30 UTC
Retested it on 2 rhevm 3.6.0-15 setups, and it works OK:

1. Set RemapCtrlAltDelDefault to 'false' & ovirt-engine service restart.
2. Create new VM, with SPICE console
3. Goto Console Options - see that "Map control-alt-del shortcut to
ctrl+alt+end" check box is empty, as expected. Also checked inside VM console,
no response/reboot following ctrl+alt+end.   

probably missed to do the ovirt-engine restart, when tested it before.
Moving to verified.

Comment 12 errata-xmlrpc 2016-03-09 20:54:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.