Bug 1184525 - Cannot install imsettings update due to changed dbus-send location
Summary: Cannot install imsettings update due to changed dbus-send location
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: imsettings
Version: 21
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-21 15:46 UTC by Marc Dionne
Modified: 2015-01-28 19:59 UTC (History)
13 users (show)

Fixed In Version: imsettings-1.6.8-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-28 19:59:30 UTC


Attachments (Terms of Use)

Description Marc Dionne 2015-01-21 15:46:21 UTC
Description of problem:

dnf check-update indicates that updated imsettings packages are available:

imsettings.x86_64                                            1.6.8-1.fc21                                   updates-testing
imsettings-gsettings.x86_64                                  1.6.8-1.fc21                                   updates-testing
imsettings-libs.x86_64                                       1.6.8-1.fc21                                   updates-testing
imsettings-xfce.x86_64                                       1.6.8-1.fc21                                   updates-testing

Currently installed versions are:
  imsettings-libs-1.6.7-6.fc21.x86_64
  imsettings-xfce-1.6.7-6.fc21.x86_64
  imsettings-1.6.7-6.fc21.x86_64
  imsettings-gsettings-1.6.7-6.fc21.x86_64

but "dnf update" gives:
  Dependencies resolved.
  Nothing to do.

yum update correctly finds and applies the imsettings updates.

Version-Release number of selected component (if applicable):

fedora 21, dnf-0.6.3-2.fc21.noarch

How reproducible:

Seen on 2 separate x64_64 fedora 21 machines.

Steps to Reproduce:
1.
2.
3.

Actual results:

dnf update says there is nothing to update

Expected results:

propose and prompt for updating to the 1.6.8.1 packages from updates-testing

Additional info:

Comment 2 Marc Dionne 2015-01-21 16:10:40 UTC
Still don't see how this can not be a bug (although perhaps not in dnf itself).

dnf upgrade --best
Error: nothing provides /usr/bin/dbus-send needed by imsettings-1.6.8-1.fc21.x86_64.
nothing provides /usr/bin/dbus-send needed by imsettings-1.6.8-1.fc21.x86_64.
nothing provides /usr/bin/dbus-send needed by imsettings-1.6.8-1.fc21.x86_64.
nothing provides /usr/bin/dbus-send needed by imsettings-1.6.8-1.fc21.x86_64

But /usr/bin/dbus-send is of course there as part of the dbus package, and "yum update" has no problem updating the packages.  Refreshing the dnf and yum metadata doesn't change anything.

Comment 3 Radek Holy 2015-01-21 16:59:42 UTC
The problem is that "imsettings" requires "/usr/bin/dbus-send" while "dbus" provides "/bin/dbus-send". DNF intentionaly does not contain the hack that is included in YUM to make it work. See http://dnf.readthedocs.org/en/latest/cli_vs_yum.html#dnf-provides-bin-file-does-not-find-any-packages-on-fedora

I believe that the problem should be fixed in the dbus package.

Comment 4 David King 2015-01-21 17:17:16 UTC
The F21 dbus package intentionally installs dbus-send to /bin and not /usr/bin. The change to move dbus-send to /usr/bin was made only in Rawhide (F22), and coordinated with the necessary changes in imsettings and oddjob-mkhomedir. imsettings should have the dbus-send change reverted in the F21 branch, which was done in imsettings-1.6.8-2.fc21, which is part of an update currently heading to F21:

https://admin.fedoraproject.org/updates/FEDORA-2015-0821/imsettings-1.6.8-2.fc21

Comment 5 Fedora Update System 2015-01-26 03:32:49 UTC
imsettings-1.6.8-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-0821/imsettings-1.6.8-2.fc21

Comment 6 Fedora Update System 2015-01-28 19:59:30 UTC
imsettings-1.6.8-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.