Bug 118457 - fetchmail's gsspop patch seems to cause a error loop
Summary: fetchmail's gsspop patch seems to cause a error loop
Status: CLOSED DUPLICATE of bug 115474
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: fetchmail   
(Show other bugs)
Version: 1.0
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-16 20:25 UTC by Robert Scheck
Modified: 2007-03-27 04:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-03-16 20:25:42 UTC
Description of problem:
--- snipp ---
# fetchmail -a -vvv
fetchmail: 6.2.5 querying pop.gmx.net (protocol POP3) at Tue Mar 16 
21:12:20 2004: poll started
fetchmail: POP3< +OK GMX POP3 StreamProxy ready <XXXXX.
YYYYYYYYYY@xy123>
fetchmail: POP3> CAPA
fetchmail: POP3< -ERR Unknown command.
fetchmail: Unknown command.
fetchmail: Repoll immediately on XXXXXXX@pop.gmx.net
fetchmail: POP3< +OK GMX POP3 StreamProxy ready <XXXXX.
YYYYYYYYYY@xy123>
fetchmail: POP3> CAPA
fetchmail: POP3< -ERR Unknown command.
fetchmail: Unknown command.
fetchmail: Repoll immediately on XXXXXXX@pop.gmx.net
fetchmail: POP3< +OK GMX POP3 StreamProxy ready <XXXXX.
YYYYYYYYYY@xy123>
fetchmail: POP3> CAPA
fetchmail: POP3< -ERR Unknown command.
fetchmail: Unknown command.
fetchmail: Repoll immediately on XXXXXXX@pop.gmx.net
fetchmail: POP3< +OK GMX POP3 StreamProxy ready <XXXXX.
YYYYYYYYYY@xy123>
fetchmail: POP3> CAPA
fetchmail: POP3< -ERR Unknown command.
fetchmail: Unknown command.
fetchmail: Repoll immediately on XXXXXXX@pop.gmx.net
[Ctrl + C]
fetchmail: terminated with signal 2
#
--- snapp ---

Result: I'm unable to fetch e-mails via pop3 about my mail provider,
because there is an error loop :-(

Version-Release number of selected component (if applicable):
fetchmail-6.2.5-1

How reproducible & Steps to Reproduce:
1. Get fetchmail-6.2.5-1
2. Rebuild it
3. Try to get mails from a mail provider - e.g. GMX (www.gmx.net)
  
Actual results:
So I tried to locate cause of the problem:

--- snipp ---
# grep CAPA SOURCES/*
SOURCES/fetchmail-6.2.0-gsspop.patch:       ok = gen_transact(sock, 
"CAPA");
#
--- snapp ---

I disabled that patch and rebuilded it again:

--- snipp ---
# fetchmail -a -vvv
fetchmail: 6.2.5 querying pop.gmx.net (protocol POP3) at Tue Mar 16 
21:19:47 2004: poll started
fetchmail: POP3< +OK GMX POP3 StreamProxy ready <XXXXX.
YYYYYYYYYY@xy123>
fetchmail: POP3> CAPA
fetchmail: POP3< -ERR Unknown command.
fetchmail: Unknown command.
fetchmail: Repoll immediately on XXXXXXX@pop.gmx.net
fetchmail: POP3< +OK GMX POP3 StreamProxy ready <XXXXX.
YYYYYYYYYY@xy123>
fetchmail: POP3> USER XXXXXXX
fetchmail: POP3< +OK May I have your password, please?
fetchmail: POP3> PASS *
fetchmail: POP3< +OK mailbox has 0 messages (0 octets)
fetchmail: POP3> STAT
fetchmail: POP3< +OK 0 0
fetchmail: No mail for XXXXXXX at pop.gmx.net
fetchmail: POP3> QUIT
fetchmail: POP3< +OK bye
fetchmail: 6.2.5 querying pop.gmx.net (protocol POP3) at Tue Mar 16 
21:19:51 2004: poll completed
#
--- snapp ---

Expected results & Additional info:
Without the patch "fetchmail-6.2.0-gsspop.patch" all works fine, 
here. Is it possible, that your patch contains an error which causes
the loop?

My knowledge about C isn't very good, but I think, the error is
maybe located at: fetchmail-6.2.0/pop3.c @@ -199,7 +199,12 @@ 
(changed by your patch).

Comment 1 Bill Nottingham 2004-03-16 22:49:00 UTC

*** This bug has been marked as a duplicate of 115474 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:02:01 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.