Bug 1184619 - Thunar crashes when trying to copy files to iPhone with iOS 6.1.x
Summary: Thunar crashes when trying to copy files to iPhone with iOS 6.1.x
Keywords:
Status: CLOSED DUPLICATE of bug 1183644
Alias: None
Product: Fedora
Classification: Fedora
Component: Thunar
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-21 20:30 UTC by Ali Akcaagac
Modified: 2015-01-23 23:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-23 23:16:40 UTC


Attachments (Terms of Use)
gdb bt full log (5.99 KB, text/plain)
2015-01-23 16:22 UTC, Ali Akcaagac
no flags Details

Description Ali Akcaagac 2015-01-21 20:30:39 UTC
This probably affects all versions of Thunar on probably all Fedora distros. Copying files from iPhone to the homedir for example works. Copying files from the homedir to the iPhone ends up with a crash. Nothing copied. Happens every time and even happens with all previous versions of Thunar 1.6.3/1.6.4

Comment 1 Kevin Fenzi 2015-01-23 00:31:54 UTC
Do you have a backtrace? Does abrt report the crash?

How is the iphone mounted?

Comment 2 Ali Akcaagac 2015-01-23 16:21:25 UTC
Ok here are the answers:

I don't habe abrt or libreport installed. Only thunar and it's required dependencies that it automagically pulls in.

The iPhone is connected via USB with it's original equipment. The phone is paired correctly with libimobile-tools.

For the following explaination I have rebooted the phone, plugged the cable into it and connected the phone with the USB port of the notebook.

The connecting sound appears on the phone (this *roooor* *roooor* sound from the vibration (audio off)).

The two folders show up on the xfce desktop. I click on "My name documents" and the main directory opens (the phone is NOT jailbreaked). You see the normal directories that apple provides for images, downloads, audio and so on.

Now I select some file from my homedir and put it into (Downloads) from the phones main directory.

Crash

First time crash there was a "normal exit" message inside gdb. By the way, your debug informations seem to not match the checksums.

Anyhow I tried again and it always crashed. I was able to gather the information about an dbus issue as you can see in the attached log.

Then I installed "abrt" and magically no crashes anymore. I was able to copy files since then.

I remember, that I don't have abrt or libreport installed when using GNOME 3 and this issue never happened when using nautilus.

Maybe this output helps locating the issue.

Comment 3 Ali Akcaagac 2015-01-23 16:22:00 UTC
Created attachment 983418 [details]
gdb bt full log

Comment 4 Kevin Fenzi 2015-01-23 23:16:40 UTC

*** This bug has been marked as a duplicate of bug 1183644 ***


Note You need to log in before you can comment on or make changes to this bug.