Bug 1184627 - Community Repo RPMs doesn't include attr package as a dependency
Summary: Community Repo RPMs doesn't include attr package as a dependency
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1184626 qe_tracker_everglades glusterfs-3.7.0
TreeView+ depends on / blocked
 
Reported: 2015-01-21 20:59 UTC by Niels de Vos
Modified: 2016-04-25 12:12 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7dev-0.869.gitf5e4c94.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1184626
Environment:
Last Closed: 2015-05-14 17:26:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-01-21 20:59:43 UTC
+++ This bug was initially created as a clone of Bug #1184626 +++
+++                                                           +++
+++   Use this bug to provide a patch in the master branch.   +++
+++                                                           +++

Description of problem:
When installing the Gluster 3.6.1 packages for CentOS 7 the attr package is not installed along with it and is needed. 

Installing the package manually resolves the issue.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Niels de Vos on 2015-01-21 21:57:01 CET ---

Yes, indeed. The mount.glusterfs helper script tests if getfattr is available, and if not, it will log a warning.

Note that it should not make a difference for the functionality, mounting should still succeed if the attr package is not installed.


Fix needed:

In the glusterfs.spec.in, add a "Requires: attr" for the glusterfs-fuse sub-package.

Comment 1 Kaleb KEITHLEY 2015-01-28 16:01:39 UTC
N.B. fixed in Fedora dist-git glusterfs.spec. Fix will take effect the next time packages are build in Koji. (And remember to do a git pull to update your local copy so this isn't lost.)

Comment 2 Niels de Vos 2015-03-26 16:02:54 UTC
Kaleb, I do not think this has been merged in the current master branch yet?

Comment 3 Anand Avati 2015-03-26 16:13:53 UTC
REVIEW: http://review.gluster.org/10016 (build: attr package dependency) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Anand Avati 2015-03-26 18:24:16 UTC
REVIEW: http://review.gluster.org/10016 (build: attr package dependency) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 5 Anand Avati 2015-03-27 16:52:23 UTC
COMMIT: http://review.gluster.org/10016 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ff6accece4ea0461a5623ea9d66cacea1a3268f3
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Mar 26 12:11:55 2015 -0400

    build: attr package dependency
    
    Already fixed in the Fedora dist-git glusterfs.spec
    
    Change-Id: Icad7c4527d4b83417cbb81957e7b5da8b4d36368
    BUG: 1184627
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/10016
    Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 6 Niels de Vos 2015-05-14 17:26:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:28:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:35:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Kaleb KEITHLEY 2016-04-25 12:12:41 UTC
fixed, see above. clearing the needinfo.


Note You need to log in before you can comment on or make changes to this bug.