Bug 118495 - gnucash quits with ERROR: Unbound variable: gnc:setup-gettext
gnucash quits with ERROR: Unbound variable: gnc:setup-gettext
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-16 20:27 EST by Thomas J. Baker
Modified: 2014-03-16 22:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.8.8-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-25 00:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-03-16 20:27:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Galeon/1.3.13

Description of problem:
neuromancer> gnucash
 
** WARNING **: Failed to open module gnucash/app-utils
 
** WARNING **: : could not locate gnucash/app-utils interface v.0
 
ERROR: Unbound variable: gnc:setup-gettext
neuromancer>


Version-Release number of selected component (if applicable):
gnucash-1.8.8-4

How reproducible:
Always

Steps to Reproduce:
1.run gnucash
2.
3.
    

Actual Results:  see above

Expected Results:  gnucash runs as normal

Additional info:
Comment 1 Thomas J. Baker 2004-03-16 20:32:58 EST
P.S. If you're going to do a rebuild, I got an update to one of my
bugs that said that a long standing hang with the scheduled
transaction editor has been fixed in CVS.
Comment 2 Sean Earp 2004-03-16 21:30:38 EST
Just adding a "me too" to this bug.  Installed a clean new copy of
gnucash, and I recieve the exact same error.
Comment 3 Jim Cornette 2004-03-16 21:52:22 EST
I am having the same error. As a note: gedit is also busted.

Another thing that I had to do was remove mutt and squid for the rest
of the upgrades to install. Below are the packages that installed
after removing mutt and squid.

had to remove mutt and squid to install the below:

cyrus-sasl-2.1.18-1
cyrus-sasl-devel-2.1.18-1
cyrus-sasl-md5-2.1.18-1
cyrus-sasl-plain-2.1.18-1

however, I think it is the below that messed up the application.

libbonoboui-2.5.4-2

These packages were installed today. So glibc or one of the below
might be the cause of the failure. No packages were forced with nodep
or anything.


PyQt-3.11-1
apr-0.9.4-10
atk-1.6.0-1
atk-devel-1.6.0-1
bonobo-1.0.22-8.1
bonobo-devel-1.0.22-8.1
checkpolicy-1.8-1
coreutils-5.2.1-1
cpp-3.3.3-3
e2fsprogs-1.35-7
e2fsprogs-devel-1.35-7
eel2-2.5.91-1
eel2-devel-2.5.91-1
fam-2.6.10-7
fetchmail-6.2.5-1
findutils-4.1.7-25
gcc-3.3.3-3
gcc-c++-3.3.3-3
gcc-g77-3.3.3-3
gcc-gnat-3.3.3-3
gcc-java-3.3.3-3
gftp-2.0.16-3
glade2-2.0.1-1
glibc-2.3.3-17
glibc-common-2.3.3-17
glibc-devel-2.3.3-17
glibc-headers-2.3.3-17
glibc-kernheaders-2.4-8.44
libf2c-3.3.3-3
libgcc-3.3.3-3
libgnat-3.3.3-3
gnome-vfs2-2.5.91-1
kdelibs-3.2.1-1.4
gnome-vfs2-devel-2.5.91-1
gnome-vfs2-smb-2.5.91-1
kdelibs-devel-3.2.1-1.4

gnome-pilot-2.0.10-6.1
gnome-pilot-devel-2.0.10-6.1
gnome-spell-1.0.5-4.1
gnome-user-docs-2.5.90-1
gnucash-1.8.8-4
gtk-doc-1.2-1
httpd-2.0.48-17
httpd-manual-2.0.48-17
hwdata-0.112-1
imlib-1.9.13-15.1
imlib-devel-1.9.13-15.1
intltool-0.30-1
kdebase-3.2.1-1.2
kdepim-3.2.1-2
kudzu-1.1.52-1
lftp-2.6.12-1
linc-1.0.3-3.1
linc-devel-1.0.3-3.1
linuxdoc-tools-0.9.20-12.1
lockdev-1.0.1-2.3.1
lockdev-devel-1.0.1-2.3.1
logwatch-5.1-2
lvm-1.0.3-18.1
mc-4.6.0-10.1
memprof-0.5.1-4.2
mikmod-3.1.6-24.1
mozilla-1.6-2
mozilla-js-debugger-1.6-2
mozilla-mail-1.6-2
mozilla-nspr-1.6-2
mozilla-nss-1.6-2
mrtg-2.10.5-2.1
nautilus-2.5.91-1
nfs-utils-1.0.6-12.fc2
nscd-2.3.3-17
openoffice.org-1.1.0-30
openoffice.org-i18n-1.1.0-30
openoffice.org-libs-1.1.0-30
oprofile-0.8-0.20040121.3
parted-1.6.6-2
pcre-4.5-1
pcre-devel-4.5-1
policy-1.8-16
policy-sources-1.8-16
popt-1.9-0.21
psmisc-21.4-2
rpm-4.3-0.21
rpm-python-4.3-0.21
sudo-1.6.7p5-19
ttmkfdir-3.0.9-10
wireless-tools-26-4
yelp-2.5.90-2
docbook-style-xsl-1.65.1-1
libofx-0.6.6-1
openhbci-0.9.14-2
vim-minimal-6.2.327-1

libbonoboui-2.5.4-2
libbonoboui-devel-2.5.4-2
libgcj-3.3.3-3
libgcj-devel-3.3.3-3
libgnomecanvas-2.5.91-2
libgnomecanvas-devel-2.5.91-2
libgnomeprint-1.116.0-9
libgnomeprint22-2.5.4-1
libgnomeprintui22-2.5.4-1
libgtop2-2.5.2-1
librsvg2-2.6.1-1
librsvg2-devel-2.6.1-1
libstdc++-3.3.3-3
libstdc++-devel-3.3.3-3
libxklavier-0.97-2.1
libxslt-1.1.4-1.1
libxslt-devel-1.1.4-1.1
mod_perl-1.99_12-2.1
mod_python-3.1.3-1
mod_ssl-2.0.48-17
sip-3.10.1-1
sip-devel-3.10.1-1
system-config-boot-0.2.4-1
system-logviewer-0.9.6-1
Comment 4 David Hollis 2004-03-19 07:11:58 EST
Me too
Comment 5 Jonathan Kamens 2004-03-21 01:48:20 EST
Me too.
Comment 6 Jim Cornette 2004-03-21 19:39:55 EST
I now get this error with xorg-x11 installed. A splash screen comes
up, then it crashes with the below error. SELinux is active.

 gnucash
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server
shutdown).
Comment 7 Jim Cornette 2004-03-21 19:47:58 EST
The above message was with the first installed program. After removing
the dual program installation. I got the same error as others
received, see below.

$ rpm -q gnucash
gnucash-1.8.8-1
gnucash-1.8.8-4
[jim@cornette-development jim]$ rpm -e gnucash-1.8.8-1
error: can't create transaction lock

opened up a root terminal and erased the older gnucash version.

[jim@cornette-development jim]$ gnucash
 
** WARNING **: Failed to open module gnucash/app-utils
 
** WARNING **: : could not locate gnucash/app-utils interface v.0
 
ERROR: Unbound variable: gnc:setup-gettext

This is on a system installed from 3/17 rawhide and upgraded to 3/19
version of rawhide.
Comment 8 Jim Cornette 2004-03-24 17:14:55 EST
gnucash now launches properly. Version is gnucash-1.8.8-5.

Comment 9 Bill Nottingham 2004-03-25 00:54:05 EST
Yes, it was fixed in -5.

Note You need to log in before you can comment on or make changes to this bug.