Bug 1184964 - mock builds with the nosync plugin result in nosync.so being a dependency
Summary: mock builds with the nosync plugin result in nosync.so being a dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Simacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-22 15:09 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2015-06-20 21:13 UTC (History)
15 users (show)

Fixed In Version: mock-1.2.10-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-01 16:51:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2015-01-22 15:09:40 UTC
Description of problem:
I found the following in review.txt created by 'fedora-review -b 1144801':

globus-xio-gridftp-multicast.i686: W: unused-direct-shlib-dependency /usr/lib/libglobus_xio_gridftp_multicast_driver.so /tmp/tmpCBkQGJ/lib/nosync.so

But looking at file itself:
ldd libglobus_xio_gridftp_multicast_driver.so
        linux-gate.so.1 =>  (0xf7769000)
        libglobus_xio.so.0 => not found
        libglobus_common.so.0 => not found
        libglobus_ftp_client.so.2 => not found
        libc.so.6 => /lib/libc.so.6 (0xf7556000)
        /lib/ld-linux.so.2 (0x4f585000)

LD_PRELOAD=/usr/lib/nosync/nosync.so ldd libglobus_xio_gridftp_multicast_driver.so
ERROR: ld.so: object '/usr/lib/nosync/nosync.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
        linux-gate.so.1 =>  (0xf77e4000)
        /usr/lib/nosync/nosync.so (0xf77d7000)
        libglobus_xio.so.0 => not found
        libglobus_common.so.0 => not found
        libglobus_ftp_client.so.2 => not found
        libc.so.6 => /lib/libc.so.6 (0xf75ce000)
        libdl.so.2 => /lib/libdl.so.2 (0xf75c9000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf75ae000)
        /lib/ld-linux.so.2 (0x4f585000)

It seems this is only caused by the environment variable and no permanent damage is done. So maybe everything is fine, and simply fedora-review should be taught to ignore nosync.so as a dependency...

Version-Release number of selected component (if applicable):
nosync-1.0-2.fc21.x86_64
nosync-1.0-2.fc21.i686
mock-1.2.3-1.fc21.noarch
dnf-0.6.3-2.fc21.noarch
fedora-review-0.5.2-1.fc21.noarch

Comment 1 Michael Simacek 2015-01-29 14:40:40 UTC
This has nothing to do with dnf, it's a problem in mock. Currently, it ld_preloads nosync for most of the commands it executes, but I think it should use it only for executing the package manager. It has little to no benefit to run it for rpmbuild, as package builds rarely do fsync().

Comment 2 Michael Simacek 2015-03-09 09:07:58 UTC
Should be fixed in upstream commit 63f57b1. Nosync is now enabled only for package management and posix-user manipulation.

Comment 3 Fedora Update System 2015-04-29 13:17:06 UTC
mock-1.2.8-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/mock-1.2.8-1.fc22

Comment 4 Fedora Update System 2015-04-29 13:17:29 UTC
mock-1.2.8-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mock-1.2.8-1.fc21

Comment 5 Fedora Update System 2015-04-29 13:18:26 UTC
mock-1.2.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.2.8-1.fc20

Comment 6 Fedora Update System 2015-04-29 13:19:35 UTC
mock-1.2.8-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/mock-1.2.8-1.el7

Comment 7 Fedora Update System 2015-04-29 13:26:10 UTC
mock-1.2.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.2.8-1.el6

Comment 8 Fedora Update System 2015-04-29 19:19:20 UTC
Package mock-1.2.8-1.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.2.8-1.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-6057/mock-1.2.8-1.el7
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-05-01 16:51:27 UTC
mock-1.2.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-05-02 18:09:05 UTC
mock-1.2.8-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-05-12 20:47:25 UTC
mock-1.2.8-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-06-04 11:42:33 UTC
mock-1.2.10-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/mock-1.2.10-1.el7

Comment 13 Fedora Update System 2015-06-04 11:42:37 UTC
mock-1.2.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.2.10-1.el6

Comment 14 Fedora Update System 2015-06-20 21:10:10 UTC
mock-1.2.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-06-20 21:13:50 UTC
mock-1.2.10-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.