Bug 118497 - xinitrc nees a good housecleaning
Summary: xinitrc nees a good housecleaning
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xinitrc   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-17 02:09 UTC by Mike A. Harris
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 11:58:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2004-03-17 02:09:20 UTC
xinitrc has bit rotted a bit, and needs a housecleaning.  There
is very similar code in both 'xinitrc' file and 'Xsession', it
might make sense to either merge the two or have them share a common
portion, or even to have them both generated from a master template
or something at build time, so that there is not code duplication,
and bug fixing needed in two places, but having the risk of only
getting fixed in one place.

Comment 1 Mike A. Harris 2004-04-06 05:19:50 UTC
I've done quite a bit of cleanups in xinitrc package since filing
this, however it should still have a good review of all scripts
once again to see if there are other ideas to clean things up, such
as some of the ideas Jens had with having an xinput.d dir for the IM
stuff.

Leaving this open for now.


Note You need to log in before you can comment on or make changes to this bug.