Bug 118498 - RHN Alert icon sees multiple updates, Up2Date does not
RHN Alert icon sees multiple updates, Up2Date does not
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 21:18 EST by Sean Earp
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-09 23:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Earp 2004-03-16 21:18:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040210 Firefox/0.8

Description of problem:
When running the up2date Alert tool, it finds 93 available updates. 
When I run the actual up2date program, it says that I am completely up
to date.  Runnung "yum update" finds (and installs) the 93 updates
with no problems.

Version-Release number of selected component (if applicable):
up2date-4.3.11-2.1.1

How reproducible:
Always

Steps to Reproduce:
1.Run System Tools --> Red Hat Network Alert iconn
2.Verify number of available updates
3.Run up2date
    

Actual Results:  Reulsts between the two similar utilities do not
correspond

Expected Results:  up2date should download and install all available
updates.

Additional info:

Rating severity as High, due to the fact that up2date is the primary 
update mechanism for the Fedora Core 2 testing.
Comment 1 Richard Ayer III 2004-03-19 22:19:41 EST
I see this a lot as well, and which mirror(s) it happens on at any
given time seems to be random. I think it has happened with every
version of yum/up2date that has existed in FC2T1. Also, today when I
had this problem I checked one of the mirrors that it happened with
using gftp; I browsed to the appropriate directories, and there were
the headers and then the packages. I thought maybe the packages
weren't there, but I was wrong. If I wait a few hours the problem
usually goes away. Another observation that may help pin this down, it
also happens if I run yum from the command line. I believe yum is the
behind-the-scenes workhorse for up2date, right?
I hope my comments have been helpful.
Comment 2 Darin May 2004-03-26 22:40:48 EST
For some reason the icon was reporting 4 updates while up2date and yum
could only find 3.  The package in question was switchdesk-4.0.1-1.1
and switchdesk-gui-4.0.1-1.1.  Manually downloading them and doing an
rpm -U got things back in sync.  Don't understand why they were
filtered out.
Comment 3 Sean Earp 2004-05-09 23:05:21 EDT
The problem has not occured for me lately.  I would guess that it is
an issue with the mirrors not being fully syncd with the master Redhat
site.  Closing out bug.

Note You need to log in before you can comment on or make changes to this bug.