Bug 1185057 - [RFE] update/backport the w_await and r_await statistics in iostat (added in sysstat 9.1.2)
Summary: [RFE] update/backport the w_await and r_await statistics in iostat (added in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sysstat
Version: 6.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Branislav Náter
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1172231 1254457 1269889 1272873
TreeView+ depends on / blocked
 
Reported: 2015-01-22 19:38 UTC by Karl Hastings
Modified: 2016-05-10 20:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
"iostat" now supports separate statistics for `r_await` and `w_await` The "iostat" tool now supports separate statistics for `r_await` (average time for read requests issued to the device to be served) and `w_await` (average time for write requests issued to the device to be served) in the Device Utilization Report. Use the "-x" option to obtain a report which includes this information.
Clone Of:
Environment:
Last Closed: 2016-05-10 20:31:26 UTC


Attachments (Terms of Use)
sysstat-9.0.4-rw-await.patch (1.79 KB, patch)
2015-02-09 15:41 UTC, Peter Schiffer
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0790 normal SHIPPED_LIVE sysstat bug fix and enhancement update 2016-05-10 22:36:53 UTC

Description Karl Hastings 2015-01-22 19:38:18 UTC
Description of problem:
Later versions of iostat have two additional columns which will give you the ‘await’ time for read and write separately, splitting them out, r_await and w_await.

Version-Release number of selected component (if applicable):
sysstat-9.0.4-27.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. iostat -x


Actual results:
[root@rhel6 ~]# iostat -x
Linux 2.6.32-431.29.2.el6.x86_64 (rhel6.example.com) 	01/22/2015 	_x86_64_	(1 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0.16    0.00    0.08    0.09    0.00   99.68

Device:         rrqm/s   wrqm/s     r/s     w/s   rsec/s   wsec/s avgrq-sz avgqu-sz   await  svctm  %util
vda               0.59     7.22    1.11    0.33    93.18    59.90   105.67     0.01    6.98   0.70   0.10
dm-0              0.00     0.00    1.55    7.49    92.07    59.88    16.80     0.85   94.47   0.11   0.10
dm-1              0.00     0.00    0.04    0.00     0.31     0.02     8.00     0.00    0.46   0.22   0.00


Expected results:
[root@rhel7 cron.d]# iostat -x
Linux 3.10.0-123.13.2.el7.x86_64 (rhel7.example.com) 	01/22/2015 	_x86_64_	(1 CPU)

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           7.45    0.00    0.72    0.14    0.00   91.69

Device:         rrqm/s   wrqm/s     r/s     w/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await r_await w_await  svctm  %util
vda               0.08     0.21    6.67   11.58   297.77   525.00    90.20     0.02    1.17    0.65    1.47   0.62   1.13
dm-0              0.00     0.00    6.72   11.79   297.30   524.82    88.86     0.03    1.36    0.77    1.69   0.64   1.18
dm-1              0.00     0.00    0.49    1.11    11.84    11.49    29.24     0.01    3.31    1.53    4.09   1.05   0.17


Additional info:


r_await and w_await were introduced in the 9.1.2 development branch.

In order to get that we'd need to either cherry pick the commit or upgrade to at least a 10.0.X branch

Then again RHEL7 is shipping a development branch, so maybe we can ship 9.1.2+ for rhel6

Comment 2 Peter Schiffer 2015-02-09 15:41:08 UTC
Created attachment 989751 [details]
sysstat-9.0.4-rw-await.patch

Comment 3 Peter Schiffer 2015-02-09 15:44:57 UTC
Hello,

I've attached patch which backports this feature to the RHEL-6, and I've proposed this bug for RHEL-6.8 as sysstat is not updated in 6.7. Unfortunately, this late in the cycle, I can't make any promises that sysstat will be updated in RHEL-6. If this feature is important for you, please talk to the PM.

Thanks,

peter

Comment 12 errata-xmlrpc 2016-05-10 20:31:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0790.html


Note You need to log in before you can comment on or make changes to this bug.