Bug 118511 - cms upgrade from 6.0.0 to 6.0.1 : bug in sql script update-bundle-type-id.sql
Summary: cms upgrade from 6.0.0 to 6.0.1 : bug in sql script update-bundle-type-id.sql
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 108447
TreeView+ depends on / blocked
 
Reported: 2004-03-17 08:42 UTC by durnez
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 19:05:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description durnez 2004-03-17 08:42:28 UTC
Description of problem:

when running :
cms/sql/default/upgrade/6.0.0-6.0.1/update-bundle-type-id.sql

and with a database having a content item with several pending instances, 
the following error occurs :
ERROR at line 1:
ORA-01427: single-row subquery returns more than one row

The reason why this exception occurs is because the inner query
retrieves several values when the content item has several pending
instances.

The solution is to replace in file
cms/sql/default/upgrade/6.0.0-6.0.1/update-bundle-type-id.sql
 :
> set type_id = (select i.type_id
by
> set type_id = (select distinct i.type_id

Version-Release number of selected component (if applicable):
CMS 6.0.0 (for upgrade to 6.0.1)

How reproducible:
always

Comment 1 Dennis Gregorovic 2004-03-17 19:05:45 UTC
Thanks for catching this.  The changes have been checked in.  


Note You need to log in before you can comment on or make changes to this bug.