Bug 1185136 - blank screen after logging in
blank screen after logging in
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cockpit (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1197412 (view as bug list)
Depends On:
Blocks: F22BetaBlocker
  Show dependency treegraph
 
Reported: 2015-01-22 23:31 EST by Chris Murphy
Modified: 2015-03-09 04:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: cockpit-0.41-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-09 04:30:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (141.34 KB, image/png)
2015-01-22 23:31 EST, Chris Murphy
no flags Details
firefox console (1.99 KB, text/plain)
2015-03-03 11:19 EST, Chris Murphy
no flags Details
chrome console (295 bytes, text/plain)
2015-03-03 11:19 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2015-01-22 23:31:20 EST
Created attachment 983172 [details]
screenshot

Description of problem: After logging in, I'm met with a white screen (see attachment) with some graphics "cockpit" at the top, but no navigable interface at all.


Version-Release number of selected component (if applicable):
cockpit-0.36-1.fc22.i686

How reproducible:
Always.


Steps to Reproduce:
1. Fedora 21 Server installed and working, including cockpit.
2. fedup upgrade to Fedora 22 Server, reboot2x
3. Go to url:9090
4. login successfully, and then


Actual results:

blank page, with cockpit graphic at the top, no other elements to navigate


Expected results:

New hotness, not new brokenness.

Additional info:

The one latent problem as a result of the fedup upgrade is that openlmi and tog-pegasus are not installed and cannot be installed due to bug 1185133. Uncertain if that's related.
Comment 1 Chris Murphy 2015-01-22 23:35:40 EST
OK, small lie. I do have navigation hidden in the far upper right corner. That pull down menu does drop down, containing language, about, account, password, privileges, and log out. When I click on each of them:

Display Language: dialog appears, no contents - nothing to select.

About Cockpit: only a partial description appears, the rest seems cut off.
"Cockpit is an advanced application with many options.
Version ."

Account Settings does nothing when clicked.

Set Password: a message "the passwords do not match" before I've typed anything, I'm not going to try to change the password here, but this is a strange message.

Log out works.
Comment 2 Chris Murphy 2015-01-24 00:14:17 EST
Same results with a new clean Fedora 22 installation, so this problem isn't fedup related.
Comment 3 Fedora Blocker Bugs Application 2015-02-17 16:01:36 EST
Proposed as a Blocker for 22-beta by Fedora user chrismurphy using the blocker tracking app because:

 It must be possible to log in to the default Cockpit instance and use it to: View the system's logs;View the system's running services;Enrol the system to a FreeIPA or Active Directory domain.
Comment 4 Dan Mossor [danofsatx] 2015-02-23 13:05:03 EST
Discussed at today's blocker review meeting [1].

AcceptedBlocker Beta - This bug is a clear violation of the Beta criterion: "It must be possible to log in to the default Cockpit instance and use it to: View the system's logs; View the system's running services; Enrol the system to a FreeIPA or Active Directory domain."

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-02-23/
Comment 5 Chris Murphy 2015-02-27 20:10:58 EST
Still a problem with Alpha TC7 new installation
https://dl.fedoraproject.org/pub/alt/stage/22_Alpha_TC7/Server/i386/os/images/boot.iso
cockpit-0.39-1.fc22.i686
Comment 6 Petr Schindler 2015-03-02 14:28:48 EST
*** Bug 1197412 has been marked as a duplicate of this bug. ***
Comment 7 Stef Walter 2015-03-03 10:07:13 EST
Chris, if you press Ctrl-Shift-J in your browser, and click the 'Console' tab, do you see any messages there when you load Cockpit? Could you paste them in this bug?
Comment 8 Fedora Admin XMLRPC Client 2015-03-03 10:11:52 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Chris Murphy 2015-03-03 11:19:04 EST
Created attachment 997576 [details]
firefox console
Comment 10 Chris Murphy 2015-03-03 11:19:28 EST
Created attachment 997577 [details]
chrome console
Comment 11 Stef Walter 2015-03-03 13:17:46 EST
This bug is relevant on non-x86_64 architectures, and caused by the lack of a cockpit-docker package.
Comment 12 Stef Walter 2015-03-03 15:24:31 EST
Fix here: https://github.com/cockpit-project/cockpit/pull/1881
Comment 13 Fedora Update System 2015-03-04 11:15:13 EST
cockpit-0.41-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/cockpit-0.41-1.fc22
Comment 14 Chris Murphy 2015-03-04 15:25:53 EST
Confirm clean AlphaTC7 install + cockpit-0.41-1.fc22 fixes this bug.

Further confirm passes test case:
https://fedoraproject.org/wiki/QA:Testcase_Server_cockpit_basic

And finally confirm that cockpit is badass (urbandic version, not google version).
Comment 15 Fedora Update System 2015-03-04 16:06:43 EST
Package cockpit-0.41-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cockpit-0.41-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3059/cockpit-0.41-1.fc22
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2015-03-09 04:30:22 EDT
cockpit-0.41-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.