Bug 118516 - xsane scans over and over again
xsane scans over and over again
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-17 06:48 EST by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-11 04:26:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My kernel config (21.11 KB, text/plain)
2004-03-18 09:00 EST, Daniel Malmgren
no flags Details
~/.sane/xsane/Hewlett-Packard:psc1100series.drc (1.49 KB, application/octet-stream)
2004-12-08 06:07 EST, Daniel Malmgren
no flags Details

  None (edit)
Description Daniel Malmgren 2004-03-17 06:48:48 EST
Description of problem:
xsane scans images over and over again

Version-Release number of selected component (if applicable):
xsane-0.92-7
sane-backends-1.0.13-5.1
hpoj-0.91-6

How reproducible:
100%

Steps to Reproduce:
1. Scan an image in xsane

Actual results:
Images are scanned allright. Problem is that when xsane is finished
scanning it starts over again, scanning the same image. Pressing
cancel during scan just makes it start from the beginning again. This
repeats over and over again until i quit the program.

Expected results:
Scan the image once and then wait til I tell it to scan another.

Additional info:
It doesn't seem to matter whether xsane is set to view, save etc.
While in view mode it opens up a new viewer window for every time it
scans the image, in save mode I get a requester about the file already
existing for every loop.
I get no error messages whatsoever.
Using a HP psc 1110, using hpoj driver.
Comment 1 Tim Waugh 2004-03-17 10:23:15 EST
Is this something that worked for you in a previous release? (Which?)
Comment 2 Daniel Malmgren 2004-03-17 11:43:58 EST
Yep. Problem is I don't really know when I last used my scanner :-/ I
asked my girlfriend and she says when she last scanned "a couple of
weeks ago" it worked allright. My best guess is that that was 0.92-5.
According to the changelog nothing important has changed since then
though, so it's something of a mystery...
Comment 3 Tim Waugh 2004-03-18 08:14:41 EST
Well, did it work in Fedora Core 1, for example?  How are you updating
this machine?
Comment 4 Daniel Malmgren 2004-03-18 08:21:59 EST
In fc1 it worked good, these strange things started just a couple of
weeks ago. The machine is updated using yum.

I could test downgrading to 0.92-5 if I just had the rpm. Where can I
find that?
Comment 5 Tim Waugh 2004-03-18 08:28:44 EST
It's really unlikely to be xsane -- there are no code changes since
0.92-5.

What kernel are you running?
Comment 6 Daniel Malmgren 2004-03-18 08:59:26 EST
Self compiled 2.6.3 (no patches, vanilla from kernel.org). I'll attach
my .config, haven't found any problems there myself though. Compiled
my kernel feb 19, it has been working after that.
Comment 7 Daniel Malmgren 2004-03-18 09:00:08 EST
Created attachment 98650 [details]
My kernel config
Comment 8 Tim Waugh 2004-03-18 09:13:20 EST
What did you use before that?  Seems like it might coincide with the
failure..

Does the same problem occur with a Fedora devel kernel?
Comment 9 Daniel Malmgren 2004-03-18 09:26:06 EST
I think I used 2.6.2-rc3 before that. But since xsane worked a couple
of weeks ago and my kernel is a month old I don't think that's the
problem. Well, downloading a fedora kernel rpm and trying won't hurt,
I'll try that and report back afterwards.
Comment 10 Daniel Malmgren 2004-03-18 10:01:02 EST
After working for a while trying to get anything at all to work with
fedora kernel I give up. I think I've adapted quite much of my
configuration to my own kernel config, it'll be too much work
configuring everything back to working with fedora kernel. Sorry...
Comment 11 Daniel Malmgren 2004-03-19 03:49:47 EST
Ok. After a couple more hours of work I succeeded to get the fedora
kernel running and I can confirm that the problem is still there, so
it can't be a kernel issue.
Comment 12 Daniel Malmgren 2004-04-05 08:52:18 EDT
Upgraded to 2.6.5 today and noticed this bug is still there. Quite
sure now it isn't a kernel issue...
Comment 13 Tim Waugh 2004-12-07 09:18:12 EST
Perhaps "Batch scan" is checked in the advanced options window?
Comment 14 Daniel Malmgren 2004-12-07 09:38:28 EST
Nope, it isnt...
Comment 15 Tim Waugh 2004-12-07 10:08:29 EST
Which version of xsane are you using now?  Does "scanimage > scanned.pnm" do the
same thing?
Comment 16 Daniel Malmgren 2004-12-07 12:47:53 EST
scanime works just fine, I don't get the same result there.

I just tried upgrading xsane to 0.95. Sadly enough that version doesn't start at
all, so I can't say whether this bug is still there. I'll file another bug about
that.
Comment 17 Daniel Malmgren 2004-12-08 04:29:46 EST
Ok, now xsane works again. This bug is still there though. I tried
removing xsane configuration file (to solve #142148), it doesn't seem
to solve this one though.

I now use the latest rawhide versions:
xsane-0.95-1
sane-backends-1.0.15-7
Comment 18 Tim Waugh 2004-12-08 04:52:51 EST
What does this say?:

grep -1w adf .sane/xsane/*
Comment 19 Daniel Malmgren 2004-12-08 06:05:06 EST
[~$] grep -1w adf .sane/xsane/*
.sane/xsane/Hewlett-Packard:psc1100series.drc-""
.sane/xsane/Hewlett-Packard:psc1100series.drc:"xsane-adf-scansource"
.sane/xsane/Hewlett-Packard:psc1100series.drc-"Flatbed"
Comment 20 Daniel Malmgren 2004-12-08 06:07:10 EST
Created attachment 108100 [details]
~/.sane/xsane/Hewlett-Packard:psc1100series.drc

I'll attach the entire file...
Comment 21 Tim Waugh 2004-12-08 06:19:53 EST
Change this line:

"Flatbed"

to read:

(nil)

Does that help?
Comment 22 Daniel Malmgren 2004-12-08 06:28:57 EST
Yep. That did the trick!

Is this xsane misinterpreting it's own settings?
Comment 23 Tim Waugh 2004-12-08 06:38:10 EST
Not sure what the cause is.  Can you find which preference switch in the GUI
affects that setting?
Comment 24 Daniel Malmgren 2004-12-08 06:55:51 EST
I can't seem to find any setting for it. When I tried removing the drc file and
then starting xsane the file was back, with working settings, so this maybe is a
fault in some earlier xsane version?

Oh, btw, the setting is now not (nil) but "", seems to do the same difference.
Comment 25 Nils Philippsen 2005-10-11 04:26:23 EDT
As this seems to have been a transient, not reproducible bug, I'll close it.

Note You need to log in before you can comment on or make changes to this bug.