Bug 118517 - Add remove applicatons all messed up
Add remove applicatons all messed up
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-17 06:48 EST by Rainer Koenig
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-30 05:08:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2004-03-17 06:48:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20040130 Firebird/0.7

Description of problem:
I downloaded the ISO images for yarrow-x86_64 and burned the CDs.
Installation as "Workstation" went fine, the CD media check at the
start also reported no errors.

Then I wanted to install the packages from the section "kernel
development". The GUI asked me to insert "yarrow" CD1 and I did so,
but I got that question again and again. 



Version-Release number of selected component (if applicable):
redhat-config-packages-1.2.7-1

How reproducible:
Always

Steps to Reproduce:
1. Install from x86_64 CDs (Fedora Core 1 for x86_64)
2. Use "Workstation" as "flavor"
3. After system is up try to install section "kernel development"
    

Actual Results:  Installer asks for CD1 but doesn't recognize the CD
at all. Media is correct due to check before install. No way out of
this, the message box that tells me to insert the correct media is
showing up again and again and if you click on cancel nothing is going
to be installed.

Expected Results:  Installation without errors.

Additional info:

Looking in the .discinfo files of the CD I find the first 2 lines like
this:
1077852656.247194
yarrow

Looking into /usr/share/comps/x86_64/.discinfo the first 2 lines are:
1077863772.587373
Yarrow

If I replace the first 2 lines in /usr/share/comps/x86_64/.discinfo
with the content of the CD's .diskinfo file then I don't get the
question about the CD any more if the requested CD is inserted. 
BUT then the next problem appears: I get an "error during
installation". Looking at the output of redhat-config-packages it
complains that the requested package is not on the CD. For example:
for libacl-devel-2.2.7-2.x86_64.rpm the installer requests CD#1 but
in fact the RPM file is located on CD#3. So it looks like the lookup
table to find out which RPM is where is totally messed up.
Comment 1 Rainer Koenig 2004-04-30 05:08:17 EDT
Problem is solved in Fedora Core 2 test 3. 

Note You need to log in before you can comment on or make changes to this bug.