Bug 118518 - gmp inclusion of SSE2 optimized libs causes Illegal Instructions on non-Pentium systems
Summary: gmp inclusion of SSE2 optimized libs causes Illegal Instructions on non-Penti...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-17 12:21 UTC by Brian Bruns
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 2.3.3-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 17:22:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:384 normal SHIPPED_LIVE Updated glibc packages 2004-09-02 04:00:00 UTC

Description Brian Bruns 2004-03-17 12:21:48 UTC
Description of problem:
gmp-4.1.2-13 includes SSE2 optimized libraries in /usr/lib/sse2 in the
default i386 package.  ld picks up on these libraries, even on a non
Pentium processor (like my Athlon XP 2000+) and loads these instead of
the generic ones in /usr/lib.

This causes Illegal Instruction errors in applications that link with
the libraries (clamav being the prime example) until either an older
version of gmp is installed (such as 4.1.2-9) or the sse2 directory is
moved out of the way and ldconfig is rerun.

Version-Release number of selected component (if applicable):
4.1.2-13

How reproducible:
Every time

Steps to Reproduce:
1. Install gmp-4.1.2-13.i386.rpm and gmp-devel-4.1.2-13.i386.rpm
2. try to start clamd or freshclam
  
Actual results:
binaries bomb out with Illegal Instruction while attempting to use gmp
functions

Expected results:
binaries should function normally without crashing

Additional info:
This appears to be directly related to the sse2 optimized libs.  I do
not believe that the Athlon XP series emulates sse2.

Comment 1 Bill Nottingham 2004-03-18 05:48:10 UTC
Shouldn't the dynamic loader be skipping these?

Comment 2 Bernhard Weisshuhn 2004-03-18 11:41:07 UTC
Same for me (regular Athlon). Doing s/pentium4/athlon/gi on the
specfile and recompiling cures the problems for athlons.

See also:
http://www.redhat.com/archives/fedora-test-list/2004-March/msg01039.html

Comment 3 Jakub Jelinek 2004-03-18 13:58:55 UTC
Seems to be a long standing glibc bug, testing a fix.

Comment 5 Jakub Jelinek 2004-03-22 17:22:53 UTC
Should be fixed in glibc-2.3.3-18.

Comment 6 Jay Turner 2004-08-20 13:05:42 UTC
Fix confirmed with 2.3.2-95.26.

Comment 7 Jay Turner 2004-09-02 05:57:33 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-384.html



Note You need to log in before you can comment on or make changes to this bug.