Bug 1185370 - hardcoded loglevel DEBUG
Summary: hardcoded loglevel DEBUG
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-urllib2_kerberos
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Dabašinskas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-23 14:38 UTC by Ondřej Pták
Modified: 2018-04-11 09:07 UTC (History)
4 users (show)

Fixed In Version: python-urllib2_kerberos-0.1.6-16.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-04 08:02:01 UTC


Attachments (Terms of Use)
reproducer (with changed url - not working) (668 bytes, text/x-python)
2015-01-23 14:38 UTC, Ondřej Pták
no flags Details
reproducer (with changed url - not working) (639 bytes, text/x-python)
2015-01-23 14:41 UTC, Ondřej Pták
no flags Details

Description Ondřej Pták 2015-01-23 14:38:07 UTC
Created attachment 983387 [details]
reproducer (with changed url - not working)

Description of problem:
When using urllib2_kerberos.py in script, I see in stdout debug information like this:

2015-01-23 11:13:12,860 DEBUG inside http_error_401
2015-01-23 11:13:12,860 DEBUG authreqs = ['Negotiate']

File /usr/lib/python2.7/site-packages/urllib2_kerberos.py from package python-urllib2_kerberos-0.1.6-13.fc21 contains: "log.setLevel(logging.DEBUG)". I think that there should be other value, such as "logging.WARNING".
Debug information appeared in  

Version-Release number of selected component (if applicable):
python-urllib2_kerberos-0.1.6-13.fc21

How reproducible:
always

Steps to Reproduce:
Run attached reproducer.

Actual results:
2015-01-23 12:48:24,663 DEBUG inside http_error_401
2015-01-23 12:48:24,664 DEBUG authreqs = ['Negotiate']
2015-01-23 12:48:24,664 DEBUG retry count: 1
2015-01-23 12:48:24,665 DEBUG req.get_host() returned some.server.com
2015-01-23 12:48:24,665 DEBUG authGSSClientInit() succeeded
2015-01-23 12:48:24,968 DEBUG authGSSClientStep() succeeded
2015-01-23 12:48:24,969 DEBUG authGSSClientResponse() succeeded
2015-01-23 12:48:25,749 DEBUG resp = <addinfourl at 140317978867760 whose fp = <socket._fileobject object at 0x7f9e53b6ccd0>>
2015-01-23 12:48:25,749 DEBUG resp = type <type 'instance'>
2015-01-23 12:48:25,749 DEBUG cleaning context

Expected results:
<empty output>

Additional info:
* URL was changed, probably there has to be some kerberos server .
* I can confirm fix or help with debugging.
* This works for me as fix, though I'm not sure this is the right approach:

sudo sed -i "s/setLevel(logging.DEBUG)/setLevel(logging.WARNING)/" /usr/lib/python2.7/site-packages/urllib2_kerberos.py

Comment 1 Ondřej Pták 2015-01-23 14:41:08 UTC
Created attachment 983388 [details]
reproducer (with changed url - not working)

corretting reproducer

Comment 10 Fedora Update System 2015-01-26 16:47:23 UTC
python-urllib2_kerberos-0.1.6-16.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-16.el6

Comment 11 Fedora Update System 2015-01-26 16:47:50 UTC
python-urllib2_kerberos-0.1.6-16.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-16.el7

Comment 12 Fedora Update System 2015-01-26 16:48:59 UTC
python-urllib2_kerberos-0.1.6-16.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-16.fc20

Comment 13 Fedora Update System 2015-01-26 16:50:24 UTC
python-urllib2_kerberos-0.1.6-16.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-urllib2_kerberos-0.1.6-16.fc21

Comment 14 Fedora Update System 2015-01-26 20:12:03 UTC
Package python-urllib2_kerberos-0.1.6-16.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-urllib2_kerberos-0.1.6-16.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0440/python-urllib2_kerberos-0.1.6-16.el6
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-02-04 08:02:01 UTC
python-urllib2_kerberos-0.1.6-16.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-02-04 08:03:03 UTC
python-urllib2_kerberos-0.1.6-16.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-03-08 22:40:42 UTC
python-urllib2_kerberos-0.1.6-16.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-03-08 22:42:30 UTC
python-urllib2_kerberos-0.1.6-16.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.