Bug 1185409 - update python-six to 1.9.0
Summary: update python-six to 1.9.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-six
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Matej Stuchlik
QA Contact: Branislav Náter
URL:
Whiteboard:
: 1173594 1210896 1214384 1224427 (view as bug list)
Depends On: 1206254
Blocks: 1158971 1166901 1181710 1184965 1216989 1270490 1279933
TreeView+ depends on / blocked
 
Reported: 2015-01-23 16:39 UTC by Lokesh Mandvekar
Modified: 2016-02-01 02:16 UTC (History)
25 users (show)

Fixed In Version: python-six-1.9.0-2.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 08:22:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2166 normal SHIPPED_LIVE python-six bug fix and enhancement update 2015-11-19 08:48:35 UTC

Description Lokesh Mandvekar 2015-01-23 16:39:57 UTC
Description of problem:

docker-python depends on python-six, but the version available for rhel-7 is outdated.

Current situation with docker-python is this:

>>> import docker
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/docker/__init__.py", line 20, in <module>
    from .client import Client # flake8: noqa
  File "/usr/lib/python2.7/site-packages/docker/client.py", line 34, in <module>
    import websocket
  File "/usr/lib/python2.7/site-packages/websocket/__init__.py", line 43, in <module>
    from six.moves.urllib.parse import urlparse
ImportError: No module named urllib.parse



This is taken care of with python-six-1.7.3 (which I grabbed from https://brewweb.devel.redhat.com/buildinfo?buildID=397532)

Comment 7 Bohuslav "Slavek" Kabrda 2015-03-10 13:44:56 UTC
*** Bug 1173594 has been marked as a duplicate of this bug. ***

Comment 8 Bohuslav "Slavek" Kabrda 2015-03-10 13:58:46 UTC
AFAICS python-six should be safe to update to latest upstream release (1.9.0 ATM) - upstream doesn't break backwards compatibility.

I'd highly recommend doing this, since new releases have important new features that more and more upstream projects will start relying on and it would be shame if people needed to start bundling six because of old version in RHEL 7.

Comment 9 Carl George 2015-03-10 14:12:03 UTC
I am also interested in seeing python-six in RHEL7 updated.  I'm working on porting the falcon framework (python-falcon) to RHEL7 for my own use (via copr).  I found that falcon actually needs six to at least be at version 1.4.0.  That is the version that introduces the variable six.PY2, which is used several times in falcon.

Skimming through other bug reports, I also found these bugs that could be resolved by an update to six.

#1173594 - python-cryptography
#1123451 - python-novaclient
#1090169 - python-keystoneclient

Comment 13 M. Scherer 2015-04-19 03:34:28 UTC
*** Bug 1210896 has been marked as a duplicate of this bug. ***

Comment 14 Ralph Bean 2015-04-21 16:54:08 UTC
Noting that the bodhi2 server for Fedora Infrastructure requires python-cryptography in EPEL7 (which requires a more modern python-six, here).

Comment 16 Matěj Cepl 2015-04-29 11:34:56 UTC
This upgrade now holds back upgrade to the latest python-behave which we need for QA.

Comment 17 Matej Stuchlik 2015-05-06 11:44:25 UTC
This rebase requires pytest>=2.4.0 which in turn requires python-py>=1.4.25.

Comment 19 Matěj Cepl 2015-05-20 17:27:37 UTC
(In reply to Matej Stuchlik from comment #17)
> This rebase requires pytest>=2.4.0 which in turn requires python-py>=1.4.25.

Are you sure about it? I have working COPR just with the packages included (without EPEL) https://copr.fedoraproject.org/coprs/mcepl/python-behave-epel7/ and it seems to build and work just fine just with the packages included.

Comment 20 Matej Stuchlik 2015-05-21 11:03:24 UTC
(In reply to Matěj Cepl from comment #19)
> (In reply to Matej Stuchlik from comment #17)
> > This rebase requires pytest>=2.4.0 which in turn requires python-py>=1.4.25.
> 
> Are you sure about it? I have working COPR just with the packages included
> (without EPEL)
> https://copr.fedoraproject.org/coprs/mcepl/python-behave-epel7/ and it seems
> to build and work just fine just with the packages included.

Looking at [0] at looks like you're using python-six 1.7.3, whereas this rebase is for 1.9.0, I reckon that could be why. I'm afraid I don't remember what exact feature it was that was missing from the older pytest, but there was something.
Note that the main reason for rebasing pytest was [1], not this bug.

[0] https://copr.fedoraproject.org/coprs/mcepl/python-behave-epel7/build/92841/
[1] https://bugzilla.redhat.com/show_bug.cgi?id=1206254

Comment 21 Matej Stuchlik 2015-05-25 13:55:10 UTC
*** Bug 1224427 has been marked as a duplicate of this bug. ***

Comment 22 Matej Stuchlik 2015-07-10 15:04:13 UTC
*** Bug 1214384 has been marked as a duplicate of this bug. ***

Comment 24 Carl George 2015-09-02 13:43:30 UTC
Would it be possible to make the new RHEL python-six package have a virtual provides for python2-six?

Provides: python2-six = %{version}-%{release}

That would match the latest Fedora Python Packaging guidelines [1] and would enable EPEL package maintainers to require python2-six, allowing more similarities between Fedora and EPEL spec files.

It is already possible to do this with the main python packages.

# rpm -q --whatprovides python2
python-2.7.5-18.el7_1.1.x86_64
# rpm -q --whatprovides python2-devel
python-devel-2.7.5-18.el7_1.1.x86_64

[1]: http://fedoraproject.org/wiki/Packaging:Python#Provides

Comment 28 errata-xmlrpc 2015-11-19 08:22:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2166.html


Note You need to log in before you can comment on or make changes to this bug.