Bug 1185428 - Thunar 1.6.4-1 segfaults when moving file to directory
Summary: Thunar 1.6.4-1 segfaults when moving file to directory
Keywords:
Status: CLOSED DUPLICATE of bug 1183644
Alias: None
Product: Fedora
Classification: Fedora
Component: Thunar
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-23 17:26 UTC by Ross Zwisler
Modified: 2015-01-23 23:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-23 23:17:03 UTC


Attachments (Terms of Use)

Description Ross Zwisler 2015-01-23 17:26:49 UTC
Description of problem:

Thunar 1.6.4-1 segfaults when moving a file into a directory.  To reproduce, just open thunar and drag a file onto a directory. The move will succeed but the thunar GUI will crash, and you'll see the following in /var/log/messages:

Jan 23 10:15:59 theros kernel: [91062.710327] pool[24131]: segfault at 38322e31 ip 00000031852282bc sp 00007f374a4511d8 error 4 in libdbus-1.so.3.7.11[3185200000+46000]
Jan 23 10:15:59 theros kernel: pool[24131]: segfault at 38322e31 ip 00000031852282bc sp 00007f374a4511d8 error 4 in libdbus-1.so.3.7.11[3185200000+46000]

This happens for me 100% of the time.  I downgraded back to Thunar 1.6.3-2 using yum downgrade, and it happens 0% of the time again.

I'm using a fully updated Fedora 20 system as of today, Jan 23, 2015.

Version-Release number of selected component (if applicable):

Thunar-1.6.4-1.fc20.x86_64

How reproducible:

100% of the time.

Steps to Reproduce:
1. drag a file to a directory in Thunar

Actual results:

GUI crash.

Expected results:

File should move into directory, GUI should stay alive.

Additional info:

Comment 1 Kevin Fenzi 2015-01-23 23:17:03 UTC

*** This bug has been marked as a duplicate of bug 1183644 ***


Note You need to log in before you can comment on or make changes to this bug.