Bug 1185755 - "systemctl start pmlogger" does nothing unless pmlogger.service is also enabled
Summary: "systemctl start pmlogger" does nothing unless pmlogger.service is also enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcp
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1131022
Blocks: 1185740
TreeView+ depends on / blocked
 
Reported: 2015-01-26 08:43 UTC by Marius Vollmer
Modified: 2015-05-03 00:48 UTC (History)
7 users (show)

Fixed In Version: pcp-3.10.4-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-22 22:57:21 UTC


Attachments (Terms of Use)

Description Marius Vollmer 2015-01-26 08:43:49 UTC
Description of problem:

The pmlogger service doesn't really start unless it is also enabled.

Steps to Reproduce:
1. Disable pmlogger
   # systemctl disable pmlogger
2. Start it
   # systemctl start pmlogger

Actual results:

The service announces itself as active:

# systemctl status pmlogger
● pmlogger.service - Performance Metrics Archive Logger
   Loaded: loaded (/usr/lib/systemd/system/pmlogger.service; disabled)
   Active: active (exited) since Mon 2015-01-26 10:33:46 EET; 1s ago
     Docs: man:pmlogger(1)
  Process: 3719 ExecStart=/usr/share/pcp/lib/pmlogger start (code=exited, status=0/SUCCESS)
 Main PID: 3719 (code=exited, status=0/SUCCESS)

But there aren't any pmlogger processes:

# pgrep pmlogger
<empty>

(It is normal that "/usr/share/pcp/lib/pmlogger start" exits.)

Expected results:

pmlogger should be running after starting the service.

Additional info:

Enabling pmlogger with "systemctl enable pmlogger" will allow it to start.  I think the /usr/share/pcp/lib/pmlogger script actually checks whether pmlogger is enabled (via chkconfig which redirects to systemctl is-enabled) and does nothing if it isn't.

This was frustrating to figure out.

Comment 1 Nathan Scott 2015-01-28 04:33:49 UTC
Just FYI - this is a duplicate of 1131022, from RHEL6 - I'll not mark it as such though since thats a different product & I think might muck up your issue tracking here?

See commen #c2 there in particular.

cheers.

Comment 2 Marius Vollmer 2015-01-28 08:02:13 UTC
> this is a duplicate of bug 1131022

Ok, thanks!


> I'll not mark it as such though since thats a different product & I think might muck up your issue tracking here?

I don't know how we track bugs here that affect multiple products.  If it's ok with you, I'd prefer to leave this open here until we can forget about from a Cockpit perspective.

I'll add a dependency.

Comment 3 Nathan Scott 2015-01-28 10:45:24 UTC
> If it's ok with you, I'd prefer to leave this open here

No problem at all - I expect to tackle this one in the short term, and will add a note to both bugs when done.

cheers.

Comment 4 Marius Vollmer 2015-02-24 12:06:07 UTC
Note that the behavior with "systemctl" is worse than with "service": At least "service pmlogger status" tells you that it isn't running, while "systemctl status pmlogger" will incorrectly state that pmlogger is active.

Comment 5 Fedora Update System 2015-04-16 04:08:46 UTC
pcp-3.10.4-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/pcp-3.10.4-1.fc22

Comment 6 Fedora Update System 2015-04-16 04:09:27 UTC
pcp-3.10.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pcp-3.10.4-1.fc21

Comment 7 Fedora Update System 2015-04-16 04:10:07 UTC
pcp-3.10.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pcp-3.10.4-1.fc20

Comment 8 Fedora Update System 2015-04-16 04:12:06 UTC
pcp-3.10.4-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pcp-3.10.4-1.el5

Comment 9 Fedora Update System 2015-04-17 18:19:43 UTC
Package pcp-3.10.4-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing pcp-3.10.4-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-5870/pcp-3.10.4-1.el5
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-04-22 22:57:21 UTC
pcp-3.10.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-04-28 12:58:28 UTC
pcp-3.10.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-04-28 13:15:33 UTC
pcp-3.10.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-05-03 00:48:23 UTC
pcp-3.10.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.