Bug 1185804 - Update to recent Marvell WiFi firmware from Marvell Git to properly support Surface Pro 3 WLAN/Bluetooth
Summary: Update to recent Marvell WiFi firmware from Marvell Git to properly support S...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-26 10:41 UTC by fednuc
Modified: 2017-10-14 08:55 UTC (History)
4 users (show)

Fixed In Version: linux-firmware-20150213-43.git17657c35.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-20 08:33:29 UTC
Type: Bug


Attachments (Terms of Use)

Description fednuc 2015-01-26 10:41:47 UTC
Description of problem:

With existing linux-firmware, Bluetooth doesn't work on Surface Pro 3. At one point (on FC20) WiFi performance was also unreliable with the packaged version, though I haven't tested this recently.


Version-Release number of selected component (if applicable):

20150115-42.git78535e88.fc21

How reproducible:

Install linux-firmware from repos.

Actual results:

No Bluetooth adapters found.

Additional info:

Chipset on the Surface Pro 3 is a Marvell Avastar 88W8897 (according to http://www.anandtech.com/show/8077/microsoft-surface-pro-3-review/7), so relevant firmware file will be either pcie8897_uapsta.bin or sd8897_uapsta.bin (I assume the former).

WiFi and Bluetooth work fine with firmware obtained as follows:

git clone git://git.marvell.com/mwifiex-firmware.git
sudo cp mwifiex-firmware/mrvl/* /usr/lib/firmware/mrvl

(I assume only the *8897* files actually need to be copied, but I can test if necessary).

This has been working with upstream firmware for several months now (since about August 2014), so I'm not sure why the firmware in the repos apparently from this month doesn't work?

Comment 1 Josh Boyer 2015-01-26 13:35:59 UTC
We supply firmware from the upstream linux-firmware repo.  I looks like Marvell hasn't pushed updates to the mwifiex files in that repository since November 2013, so the files are stale compared to the marvell git tree.

Why that is, I'm not sure.

Comment 2 fednuc 2015-01-26 13:55:42 UTC
Thanks for the quick reply...!

What are the options for getting newer versions into upstream in that case? I can think of:

* linux-firmware upstream pulling changes from Marvell's Git - any obstacles to this, e.g. licensing?
* Talking to Marvell to try and convince them to push their changes - ideal I guess but very dependent on Marvell's willingness/responsiveness.
* Fedora cherry-picking the specific firmware blobs from Marvell's tree - Fedora-specific but not dependent on 3rd parties - any obstacles to this as a fallback?

Can you tell me if there is anything I can do to help get the updated firmware into Fedora's RPM in any case?

Comment 3 Josh Boyer 2015-01-26 13:58:12 UTC
I sent an email to the Marvell person that is updating the marvell git tree.  We'll see what they say.

Comment 4 Fedora Update System 2015-02-13 15:38:05 UTC
linux-firmware-20150213-43.git17657c35.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/linux-firmware-20150213-43.git17657c35.fc20

Comment 5 Fedora Update System 2015-02-13 15:39:43 UTC
linux-firmware-20150213-43.git17657c35.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/linux-firmware-20150213-43.git17657c35.fc21

Comment 6 fednuc 2015-02-13 15:51:29 UTC
Is newer mwifiex firmware necessarily in the above updated packages, or are there automated posts to any bug for a given package whenever the package is updated?

If it's the latter, was there any response from Marvell yet?

Comment 7 Josh Boyer 2015-02-13 16:12:26 UTC
The updated firmware is included in the package.  The update text says so.  After contacting upstream they submitted a pull request for the updated firmware to the linux-firmware repo and it was accepted.

Comment 8 Fedora Update System 2015-02-15 02:58:52 UTC
Package linux-firmware-20150213-43.git17657c35.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20150213-43.git17657c35.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1947/linux-firmware-20150213-43.git17657c35.fc21
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-02-20 08:33:29 UTC
linux-firmware-20150213-43.git17657c35.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-03-04 10:35:39 UTC
linux-firmware-20150213-43.git17657c35.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 fedora_45sg 2017-10-14 01:23:36 UTC
Hi, 

I am using a Surface 3 non-pro and also have the problem that the wifi connection just works after boot for 1-2 min and then I am not able to connect to a network anymore, even if I disable/enable wifi again via terminal.

My wifi card needs the pcie8897_uapsta.bin. Please check if the latest firmware version is available or not in the F26 repos. Or if they need to be updated from git://git.marvell.com/mwifiex-firmware.git again manually.

Comment 12 fednuc 2017-10-14 08:55:57 UTC
WLAN on the Surface 3 Pro has been stable recently; you may want to open a separate bug for your issue.


Note You need to log in before you can comment on or make changes to this bug.