Bug 1185828 - eclipse: assertion failure during startup (GTK/CSS related)
Summary: eclipse: assertion failure during startup (GTK/CSS related)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-26 11:44 UTC by Mikolaj Izdebski
Modified: 2015-02-11 04:38 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 04:38:12 UTC


Attachments (Terms of Use)
eclipse startup log (5.35 KB, text/plain)
2015-01-26 11:44 UTC, Mikolaj Izdebski
no flags Details

Description Mikolaj Izdebski 2015-01-26 11:44:15 UTC
Created attachment 984171 [details]
eclipse startup log

Description of problem:
During startup eclipse fails with:
Gtk:ERROR:gtkstylecontext.c:338:gtk_css_node_get_parent_style: assertion failed: (cssnode->parent == NULL || cssnode->parent->values != NULL)

Version-Release number of selected component (if applicable):
eclipse-swt-4.4.1-17.fc22.x86_64
gtk3-3.15.4-1.fc22.x86_64

Steps to Reproduce:
1. run eclipse in rawhide

Actual results:
log attached

Additionally, even though Eclipse doesn't start, exit code is still 0.

Comment 1 Mat Booth 2015-01-26 12:29:27 UTC
Hmm, eclipse-pdt unit tests fail in the same way. Looking back at Koschei build history, it started failing when the following dep changed:

gtk3   3.15.3-1.fc22 --> 3.15.4-1.fc22

Comment 2 Mikolaj Izdebski 2015-01-27 04:51:09 UTC
I confirm that downgrading gtk3 package to version 3.15.3 works around this issue.

Comment 3 Alexander Kurtakov 2015-02-04 20:25:49 UTC
Should be fixed when next gtk update arrives. Fixed upstream in gtk with https://git.gnome.org/browse/gtk+/commit/?id=edec64cda3d4518b4e87d5ea5d287d4570ba9933

Comment 4 Mikolaj Izdebski 2015-02-09 07:58:19 UTC
(In reply to Alexander Kurtakov from comment #3)
> Should be fixed when next gtk update arrives. Fixed upstream in gtk with
> https://git.gnome.org/browse/gtk+/commit/
> ?id=edec64cda3d4518b4e87d5ea5d287d4570ba9933

I confirm that this patch fixes the problem.

Comment 5 Alexander Kurtakov 2015-02-09 08:37:06 UTC
Moving to gtk3 as the problem is occuring there and is fixed in upstream gtk3.


Note You need to log in before you can comment on or make changes to this bug.