Bug 118583 - rc.sysinit and network-functions do not handle whitespace correctly
Summary: rc.sysinit and network-functions do not handle whitespace correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-03-17 21:56 UTC by Lubomir Bulej
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version: 7.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 05:36:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to rc.sysinit (1.79 KB, patch)
2004-03-17 21:56 UTC, Lubomir Bulej
no flags Details | Diff
Proposed patch to network-functions (483 bytes, patch)
2004-03-17 21:57 UTC, Lubomir Bulej
no flags Details | Diff

Description Lubomir Bulej 2004-03-17 21:56:19 UTC
Description of problem:
The rc.sysinit and network-functions both parse output of modprobe to
see if the user has defined aliases for usb controllers, network
interfaces etc.

The problem is that they expect that there will be exactly one space
between the words alias and (for example) usb-controller, which fails
in case the user uses tabs or multiple spaces in his configuration files.

Comment 1 Lubomir Bulej 2004-03-17 21:56:57 UTC
Created attachment 98625 [details]
Proposed patch to rc.sysinit

Comment 2 Lubomir Bulej 2004-03-17 21:57:36 UTC
Created attachment 98626 [details]
Proposed patch to network-functions

Comment 3 Bill Nottingham 2004-05-04 05:36:07 UTC
Added in 7.51-1 - thanks!


Note You need to log in before you can comment on or make changes to this bug.