Bug 118601 - rpm-4.3-0.21 rpms in ./development tree require glibc-2.3.4, out of sync w/ other rpms; causes up2date failure
rpm-4.3-0.21 rpms in ./development tree require glibc-2.3.4, out of sync w/ o...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-17 22:33 EST by JD Gorman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-18 21:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JD Gorman 2004-03-17 22:33:11 EST
Description of problem:
rpm-4.3-0.21 references glib 2.3.4 but FC2 test1 is using glib-2.3.3
This causes problems w/ up2date (librpmio complains that GLIB_2.3.4 is
undefined and terminates up2date).  Was the development system using
glib-2.3.4? If so, it's outta sync w/ the rest of the rpms in
./development

Version-Release number of selected component (if applicable):
rpm-*-4.3-0.21 from the ./development dir

How reproducible:
Every time

Steps to Reproduce:
1. Upgraded FC1 to FC2 test
2. Installed rpm-4.3-0.21 from ./development dir
3. 
  
Actual results:
up2date, rpm busted

Expected results:
that rpm and up2date should function normally

Additional info:
workaround was to build rpm-*-4.3-0.21.i386.rpm from SRPM files and
install using: rpm -iUvh --force  
other workaround would have been to upgrade glibc to 2.3.4
Comment 1 Bill Nottingham 2004-03-18 01:02:22 EST
Installing new glibc from devel tree should get around this.
Comment 2 JD Gorman 2004-03-18 13:51:41 EST
Thanks. I think that's what I was suggesting too. The problem is that
the glibc RPM packages in the devel tree seem to be sitting at
2.3.3-17, not 2.3.4, unless I'm interpreting the numbering wrong. 
Thus it's quite easy for folks to "break" librpmio w/o realizing. 

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/
 glibc-2.3.3-17.i386.rpm          17-Mar-2004 14:40   3.3M 
Comment 3 Jeff Johnson 2004-03-18 21:40:57 EST
This is a weak symbol in glibc-2.3.3 against which rpm
was compiled.

Note You need to log in before you can comment on or make changes to this bug.