Bug 118614 - Patch schema for later upstream submission
Summary: Patch schema for later upstream submission
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-18 10:43 UTC by Warren Togami
Modified: 2015-03-03 22:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 14:10:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-vfs-2.5.91-schema_for_upstream.patch (5.38 KB, patch)
2004-03-18 10:54 UTC, Warren Togami
no flags Details | Diff

Description Warren Togami 2004-03-18 10:43:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040225 Firefox/0.8

Description of problem:
The below attached patch is necessary for the Preferred Applications
fixes in Bug #109738.  This needs to be submitted to GNOME upstream
after the 2.6 release since it is currently frozen.

Version-Release number of selected component (if applicable):
gnome-vfs2-2.5.91-2

Comment 1 Warren Togami 2004-03-18 10:54:24 UTC
Created attachment 98647 [details]
gnome-vfs-2.5.91-schema_for_upstream.patch

- s/need-terminal/needs_terminal/
- Add the about url-handler

There is still an issue I am confused about... how will end-users actually have
this schema after upgrade without doing "gconftool-2 --install-schema-file
/etc/gconf/schemas/desktop_gnome_url_handlers.schemas" manually?

Comment 2 Warren Togami 2004-03-18 10:59:15 UTC
Perhaps Bug #107994 should be fixed by adding another ftp handler? 
Sure we do not have a GUI to edit this yet like the browser or mail
client, but opening ANYTHING would be better than failing, IMHO. 
Opinions?


Comment 3 Warren Togami 2004-03-18 11:18:03 UTC
Alex mentioned the possible problems with ftp & sftp URL handling from
vfs, so deferring this until later for more testing.  For now
comitting only this fix to gnome-vfs2 for FC2, split into two patches
for easier upstream inclusion later.

Comment 4 Alexander Larsson 2004-03-19 08:42:08 UTC
The needs_terminal parts are already in upstream

Comment 5 Warren Togami 2004-10-21 10:33:33 UTC
I don't know if this is solved upstream yet.  Must be revisited.  We
had to patch stuff for FC3, but not nearly as much as we did with the
FC2 patches above.


Comment 6 Bug Zapper 2008-05-14 01:56:03 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.