Bug 118619 - kernel panic on load kernel modules with HIGHMEM enabled kernel.
kernel panic on load kernel modules with HIGHMEM enabled kernel.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 08:09 EST by Alex Lyashkov
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-08 19:56:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
oops (3.50 KB, text/plain)
2004-04-08 12:04 EDT, Alexander Suvorov
no flags Details
dmesg from machine where panic was happened (5.87 KB, text/plain)
2004-04-08 12:09 EDT, Alexander Suvorov
no flags Details

  None (edit)
Description Alex Lyashkov 2004-03-18 08:09:56 EST
Description of problem:
Kernel panic at load kernel modules with more 1G RAM in box.

Version-Release number of selected component (if applicable):
2.4.21-9.0.1

How reproducible:
run script

find /lib/modules/`uname -r` -name "*.o" -exec insrmmod {} \; 

where insrmmod:
#!/bin/sh 
echo Loading module $1... 
insmod $1
echo Module $1 has loaded
echo Releasing module $1...
rmmod $1 
echo Module $1 has released

Actual results:
Panic

Expected results:


Additional info:
Comment 1 Ernie Petrides 2004-03-18 17:45:42 EST
Could you please indicate which module load/release causes the
panic and include the oops/panic console output?  Thanks.  -ernie
Comment 2 Alex Lyashkov 2004-03-24 10:35:45 EST
Panic are in random module and random points.
Only one is equally panic in address 0xF.......
simple output
md74xx.o: Unable to handle kernel paging request at virtual address
f8ab9560
piix.o: Unable to handle kernel paging request at virtual address f8a3f560
....
Please run this cript and you all see.
Comment 3 Ernie Petrides 2004-04-07 18:49:44 EDT
It is not reasonable to try loading all modules for a given
release/architecture if the associated "unsupported" RPM has
been installed (such as kernel-smp-unsupported-2.4.21-12.EL.i686.rpm)
because some of the unsupported modules might cause crashes.

Have you installed any of the "unsupported module" RPMs?  If not,
could you please attach the exact console output that occurs from
one or two of your crashes?

Thanks.  -ernie
Comment 4 Alexander Suvorov 2004-04-08 12:04:28 EDT
Created attachment 99240 [details]
oops

panic during module loading
Comment 5 Alexander Suvorov 2004-04-08 12:09:22 EDT
Created attachment 99241 [details]
dmesg from machine where panic was happened
Comment 6 Alexander Suvorov 2004-04-08 12:13:43 EDT
these attaches for configuration: 
1Gb memory 
kernel built from kernel-2.4.21-i686-config config 
noone unsupported modules has loaded 
 
Comment 7 Alexander Suvorov 2004-04-08 12:56:24 EDT
sorry, correction to previous post: kernel configuration 
made from original kernel-2.4.21-i686-config by additional check 
highmem (4GB) support. 
Comment 8 Ernie Petrides 2004-04-21 19:57:59 EDT
Hello, Alexander.  Red Hat supports kernels/modules from the binary
RPMs that we ship (except for the modules in kernel-*unsupported*).
For example, for the config specified by kernel-2.4.21-i686.config,
we support the kernel/modules from kernel-2.4.21-9.EL.i686.rpm.

We do not support customer built kernels because various changes to
config settings can produce unreliable software, and further, when
a customer builds kernels from our kernel-source-* RPMs, all of the
unsupported modules (potentially with serious bugs) are also built.

And finally, we do not provide any support for a tainted kernel
such as is shown in the oops output in comment #4.

If you can reproduce a crash with a supported module on a supported
kernel, please indicate that in this bug report.

Thanks.  -ernie
Comment 9 Alex Lyashkov 2004-04-22 00:27:26 EDT
ernie you read my first post? or you not want find and fix bug? if you
do not want it - say it.
You run attached script ?
It`s bug provides with _DEFAULT_ kernel config and panic show at
_SUPPORTED_ modules.
If help you i can say - at some situations (i don`t find reason of it)
at process VMA have area with end < start. How i see it after fork and
COW.

I see you find any  possibilites for not work with this PR. why ?
Comment 10 Ernie Petrides 2004-04-22 04:39:49 EDT
Hello, Alex.  I have tried a similar script on a 4-GB machine in
our test lab (with a soon-to-be-released kernel version 2.4.21-9.0.3)
and was not able to reproduce a crash.  The difference between my
script and yours is that it avoided loading/unloading any module
that was already loaded before I started the test, and it also
avoided loading/unloading aic7xxx_old.o, since that conflicts
with aic7xxx.o (which is used on my test machine).

My suspicion is that you must be trying to reload/unload a module
that is necessary for your machine, or perhaps you're trying to
load a module that is incompatible with your hardware.

At this point, I simply don't know how to help you.  As I mentioned
before, Red Hat cannot provide support for customer-built or tainted
kernels, which is the only oops output provided in this bug report.

If you can somehow determine which module is giving you a problem,
and you can show an untainted-kernel crash from loading or unloading
that module, then we would be happy to debug the problem.

Cheers.  -ernie

Note You need to log in before you can comment on or make changes to this bug.