Bug 1186346 - Review Request: golang-github-influxdb-hyperleveldb-go - Go wrapper for HyperLevelDB
Summary: Review Request: golang-github-influxdb-hyperleveldb-go - Go wrapper for Hyper...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1161618
TreeView+ depends on / blocked
 
Reported: 2015-01-27 13:44 UTC by Jan Chaloupka
Modified: 2015-02-07 04:02 UTC (History)
1 user (show)

Fixed In Version: golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-07 03:53:46 UTC
Type: ---
lsm5: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Jan Chaloupka 2015-01-27 13:44:40 UTC
Spec URL: https://jchaloup.fedorapeople.org/reviews/golang-github-influxdb-hyperleveldb-go/golang-github-influxdb-hyperleveldb-go.spec

SRPM URL: https://jchaloup.fedorapeople.org/reviews/golang-github-influxdb-hyperleveldb-go/golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20.src.rpm

Description: Go wrapper for HyperLevelDB

Fedora Account System Username: jchaloup

Koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=8736926

Fedora Account System Username: jchaloup

$ rpmlint golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20.src.rpm golang-github-influxdb-hyperleveldb-go-devel-0-0.1.gite24de94.fc20.noarch.rpm golang-github-influxdb-hyperleveldb-go.spec
2 packages and 1 specfiles checked; 0 errors, 0 warnings.

Upstream: https://github.com/influxdb/hyperleveldb-go

Notes: go test does not pass because there is not rocksdb in Fedora. This is only a wrapper without database itself.

Comment 1 Lokesh Mandvekar 2015-01-27 17:55:19 UTC
- license correct and valid
- specfile conforms to current golang packaging draft
- only sources installed for now

TBD: may need to package hyperleveldb at a later point though it's not a blocker as far as getting the golang sources installed are concerned.

package approved

Comment 2 Jan Chaloupka 2015-01-27 18:00:46 UTC
New Package SCM Request
=======================
Package Name: golang-github-influxdb-hyperleveldb-go
Short Description: Go wrapper for HyperLevelDB
Upstream URL: https://github.com/influxdb/hyperleveldb-go
Owners: jchaloup lsm5
Branches: f21 f20 f19 el6
InitialCC: golang-sig

Comment 3 Gwyn Ciesla 2015-01-28 11:59:57 UTC
Git done (by process-git-requests).

Comment 4 Fedora Update System 2015-01-29 09:32:32 UTC
golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20

Comment 5 Fedora Update System 2015-01-29 09:33:38 UTC
golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc21

Comment 6 Fedora Update System 2015-01-30 04:42:10 UTC
golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20 has been pushed to the Fedora 20 testing repository.

Comment 7 Fedora Update System 2015-02-07 03:53:46 UTC
golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc21 has been pushed to the Fedora 21 stable repository.

Comment 8 Fedora Update System 2015-02-07 04:02:18 UTC
golang-github-influxdb-hyperleveldb-go-0-0.1.gite24de94.fc20 has been pushed to the Fedora 20 stable repository.


Note You need to log in before you can comment on or make changes to this bug.