Bug 118638 - please include updated wacom input driver
please include updated wacom input driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 10:47 EST by Lars G
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 21:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars G 2004-03-18 10:47:08 EST
x includes an outdated wacom input driver 
which does only work right when replaced with the current one from
linuxwacom.sf.net.
please include updated driver with future x releases so one doesn't
have to install
it manually with each x update.
will make it a lot smoother for us wacom stylus users.

thanks!
lars

ps. great work! finally x is free as in x.free ^_^
Comment 1 Mike A. Harris 2004-03-23 15:09:21 EST
It is best if the upstream Xorg sources directly include the new
wacom driver in the upcoming release instead, as that way there is
a common base, which is easier to maintain, and more consistent.

Can you file a request for enhancement for this in the upstream
bugzilla at http://bugs.freedesktop.org against the "xorg"
product?

Thanks in advance.
Comment 2 Lars G 2004-03-23 15:33:28 EST
ok, done.

thanks,
lars

Comment 3 Mike A. Harris 2004-03-23 21:06:31 EST
I've added myself to the CC on the upstream request, and will track
it there now:

http://freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=366

Thanks.

Setting status to "UPSTREAM"
Comment 4 Mike A. Harris 2004-08-30 01:46:52 EDT
Reopening for re-review.  I've updated the X.Org bug report noted
above as well.  Kristian has whipped up a linuxwacom driver rpm
which will be included in Fedora devel soon by the looks of it.

I'm reassigning this report to Kristian, as he's been investigating
the linuxwacom driver and working on that rpm package.
Comment 5 Kristian Høgsberg 2004-09-14 21:16:17 EDT
The linuxwacom package is now in fedora devel, so I'm closing this
bus.  Please give it a try, and open a new bug if you experience
problems with the package.
Comment 6 Lars G 2004-09-15 10:24:15 EDT
thanks!
works great.

minor thing was that i had to install the package with --force
without this, it complained a conflict with xorg-x11's wacom_drv.o.


cheers
lars
Comment 7 Kristian Høgsberg 2004-09-15 10:42:53 EDT
Yes, that'll be fixed with the next release of the xorg-x11 RPM.
Comment 8 Mike A. Harris 2004-09-15 16:36:54 EDT
lars) You've got an older xorg-x11 installed which has the
wacom driver included, so conflicts with installing the separate
rpm.  By forcing the installation, you may lose the wacom driver
when you upgrade, because it's marked as being owned by 2 rpm
packages now, so upgrading xorg-x11 may remove the wacom driver.

In general, you should never use --force to install rpms as it
can damage the rpm database and/or leave your system in a state
of disarray.

If this happens, just uninstall and reinstall linuxwacom again and
hopefully things should be fixed though.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.