Bug 1186403 - Packages samba-common for i686 and x86_64 are inconsistent
Summary: Packages samba-common for i686 and x86_64 are inconsistent
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Robin Hack
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1189279
TreeView+ depends on / blocked
 
Reported: 2015-01-27 15:45 UTC by Marek Hruscak
Modified: 2015-11-19 09:10 UTC (History)
11 users (show)

Fixed In Version: samba-4.2.2-1.el7
Doc Type: Known Issue
Doc Text:
Binaries in the samba-common.x86_64 and samba-common.i686 packages contain the same file paths but differ in their contents. As a consequence, the packages cannot be installed together, because the RPM database forbids this scenario. To work around this problem, do not install samba-common.i686 if you primarily need samba-common.x86_64; neither in a kickstart file, nor on an already installed system. If you need samba-common.i686, avoid samba-common.x86_64. As a result, the system can be installed, but with only one architecture of the samba-common package at a time.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 09:10:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2258 normal SHIPPED_LIVE samba bug fix and enhancement update 2015-11-19 09:22:47 UTC

Comment 3 Michael Lampe 2015-04-04 23:35:55 UTC
Thousands of foo.x86_64 and foo.i686 packages contain the same files in /usr/bin but differ in their contents. Of course they do. RPM resolves this by prefering the x86_64 binary. That's how biarch works and always has worked. That you can only install one flavour of samba-common in el7 is a clear packaging bug.

Comment 4 Benjamin Ash 2015-04-06 16:56:40 UTC
We are currently blocked/hobbled by this issue since we set Yum's multilib_policy to 'all', and then perform a group installation of a group that includes 'samba-common'. I noticed the previous release of CentOS 7's yum repository does not contain samba-common.i686 (any build), but the latest one repo does. Perhaps samba-common.i686 could be removed from the repos.

As a work around we had to 'exclude' samba-common.i686 from all repos providing it.

Comment 8 Brett Randall 2015-11-03 08:42:05 UTC
In a package-update scenario, I worked-around this by removing the samba packages and then reinstalling them after the update completed, but using the full package-version-arch names (on an x86_64 system):

$ yum remove samba-winbind-client samba-common samba-common samba-winbind-modules samba-libs
$ yum update
$ yum install samba-winbind-client-4.1.12-23.el7_1.x86_64 samba-common-4.1.12-23.el7_1.x86_64 samba-winbind-modules-4.1.12-23.el7_1.x86_64 samba-libs-4.1.12-23.el7_1.x86_64

Mentioning this in-case it provides a simple workaround for anyone who meets this issue.

Comment 10 errata-xmlrpc 2015-11-19 09:10:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2258.html


Note You need to log in before you can comment on or make changes to this bug.