Bug 1186414 - Our Celery packages depend on the existence of the apache user
Summary: Our Celery packages depend on the existence of the apache user
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: async/tasks
Version: 2.4.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-27 15:59 UTC by Randy Barlow
Modified: 2015-02-28 23:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 23:21:35 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 678 0 None None None Never

Description Randy Barlow 2015-01-27 15:59:28 UTC
Description of problem:
If users wish to install our Celery packages on a system that does not have httpd installed, the apache user will not exist. However, the Celery packages all assume that the apache user does exist. There is a reasonable workaround[0], but we could also take steps to fix this such as creating a "pulp" user and running all processes as it. We could also attempt to create the apache user ourselves, though I believe the pulp user may be more appropriate. In any case, it will be important for us to ensure that the user always has the same UID/GID. Using the existing "apache" user might help with this, as it seems to always have UID:GID of 48:48 for Red Hat based systems (I checked F20 and RHEL 7.)

Version-Release number of selected component (if applicable):
2.4.3-1

How reproducible:
Every time.

Steps to Reproduce:
1. Configure a Pulp worker box that does not have httpd installed on it.
2. Attempt to start the workers.

Actual results:
The workers will fail to start, because the system will attempt to run them as the apache user, which does not exist.

Expected results:
The workers should start out of the box.

Additional info:
[0] A workaround is to manually create the apache user, using the same UID/GID as it has on the other systems that are sharing the filesystem.

Comment 1 Brian Bouterse 2015-02-28 23:21:35 UTC
Moved to https://pulp.plan.io/issues/678


Note You need to log in before you can comment on or make changes to this bug.