Bug 118671 - Error parsing at spec file on ia64 with IBM 1.3.1 JVM
Summary: Error parsing at spec file on ia64 with IBM 1.3.1 JVM
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: RPM Plug-in (Show other bugs)
(Show other bugs)
Version: 2.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matt Newsome
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-18 19:41 UTC by Jeremy Handcock
Modified: 2015-05-05 07:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-05 07:58:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Handcock 2004-03-18 19:41:04 UTC
Description of problem:  SRPM import of the at SRPM fails on ia64 with
the IBM 1.3.1 JVM.

How reproducible: Always


Steps to Reproduce:
1. Create C project
2. Import at SRPM from RPM test plan into the project
  
Actual results: Error dialog: "Error parsing spec file at
/var/tmp/handcock/rpm_workspace/SPECS/at.spec"

Expected results: Import the SRPM.

Additional info: This works on the ia64 JRockit JVM, so I assume this
to be a bug in IBM's 1.3.1 JVM.  This will be a consideration in
deciding what JVM to use on ia64.

Comment 1 Jeremy Handcock 2004-03-18 20:11:55 UTC
I had the same problem when exporting the pump RPM/SRPM in the test
plan, but only on the IBM JVM.  Works fine on JRockit.

Comment 2 Jeremy Handcock 2004-03-18 21:16:14 UTC
I also got the IBM JVM to dump core once when exporting the pump RPM.
 This JVM is looking worse and worse.

Comment 3 Aaron Luchko 2004-07-22 00:31:42 UTC
Happens on x86 with IBM JVM, only got it with the "at" rpm the others
look fine.  Seems pretty likely it's a jvm issue.

Comment 4 Aaron Luchko 2004-07-22 01:23:25 UTC
Got it again exporting PUMP, hadn't made any changes to the spec file.

Comment 5 Aaron Luchko 2004-07-22 01:29:53 UTC
Forgot to throw in these that showed up on the console when doing the
export on pump, these didn't show up with the import on at though

 Unhandled event loop exception
Reason:
java.lang.NullPointerException
Unhandled event loop exception
Reason:
java.lang.NullPointerException
Unhandled event loop exception
Reason:
java.lang.NullPointerException



Comment 6 Aaron Luchko 2004-07-22 15:28:17 UTC
Forgot to mention, the jvm I was using was jre-1.4.2-ibm 

Comment 7 Andrew Overholt 2004-11-18 16:21:14 UTC
This happens with IBM's 1.4.2 on ia64 now as well (but not BEA's).

Comment 8 Rick Moseley 2004-11-23 16:39:05 UTC
I have the same problem about parsing the specfile on the IBM 1.4.2
JVM on RHEL3, but only with the pump source RPM.  I get double
characters when I enter data into the patch tag name.  This problem
does not occur with the BEA JVM or the Sun JVM.

Comment 11 Matt Newsome 2015-05-05 07:58:40 UTC
Closing this bug out due to its age and the assigned product.


Note You need to log in before you can comment on or make changes to this bug.