This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 118672 - up2date doesn't resolve when using a proxy
up2date doesn't resolve when using a proxy
Status: CLOSED DUPLICATE of bug 102272
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 14:46 EST by Harold Reed
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harold Reed 2004-03-18 14:46:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
up2date will not use proxy settings that I'm manually putting in. I've
tried manually vi'ing the config files and I've put in the information
in the "Configuration..." information time and again. The
"configuration..." information doesn't seem to be kept: each time I
look at the configuration the check boxes are unchecked after I've
re-checked them from before. I've put in a proxy server in the
"Network Proxy" settings and that doesn't seem to change anything. I
get python errors pretty consistently. The last python error I get
when I initiate up2date from the command line is:

urllib2.URLError: <urlopen error (-2, 'Name or service not known')>
TypeError: hide() takes no arguments (2 given)

I've done a capture when up2date tries to go out to the Internet and
there's no attempt to use the proxy. The workstation is attempting to
use it's DNS servers (/etc/resolv.conf) to resolve the name. It's not
forwarding the request to the proxy to allow it to proxy the connection. 

The alert notification tool works fine and other tools/browsers (wget,
Firefox, etc.) work just fine from the same workstation, so I know I
can get out. The alert notification tool tells me all the updates
available so that's getting out just peachy, but up2date hangs because
it's not forwarding the request to the proxy. I can show the capture
if it would help.

Version-Release number of selected component (if applicable):
up2date-4.1.21-3

How reproducible:
Always

Steps to Reproduce:
1. Double click the alert notification tool. "Launch up2date..." This
also works from command line.
2. Click "Forward..."
3. up2date attempts to resolve the update servers locally and will not
send through the proxy.
    

Actual Results:  The traffic goes no where.

Expected Results:  up2date connects to the proxy to fulfill the request.

Additional info:
Comment 1 William Hooper 2004-03-21 13:48:23 EST
Duplicate of bug 102272
Comment 2 Adrian Likins 2004-04-07 16:40:04 EDT

*** This bug has been marked as a duplicate of 102272 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.