Bug 1186789 - "Refreshing capabilities" should keep host in maintenance.
Summary: "Refreshing capabilities" should keep host in maintenance.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.3
Hardware: All
OS: Linux
medium
high
Target Milestone: ovirt-3.6.2
: 3.6.2
Assignee: Eli Mesika
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-28 14:36 UTC by Ulhas Surse
Modified: 2019-10-10 09:35 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:55:34 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Ulhas Surse 2015-01-28 14:36:58 UTC
3. What is the nature and description of the request?  
      "Refreshing capabilities" of a host should not result in the host being brought out of maintenance

    4. Why does the customer need this? (List the business requirements here)  
      "Refreshing capabilities" can be a precursor to further work, having it bring the host out of maintenance mode is counter intuitive. 

    5. How would the customer like to achieve this? (List the functional requirements here)  
      "Refreshing capabilities" of a host should not result in the host being brought out of maintenance.  That should be done by clicking on "activate".

    6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
      
    7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
      No

    8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
       No

    9. Is the sales team involved in this request and do they have any additional input?  
       No

    10. List any affected packages or components.  
        RHEVM 

    11. Would the customer be able to assist in testing this functionality if implemented?  
        Yes

Comment 2 Eli Mesika 2015-02-03 15:00:28 UTC
Was unable to reproduce

1) Installed a host and wait until it is active
2) Set host to Maintenance 
3) Right click menu => Refresh Capabilities

Result : host stays in maintenance after this operation

Comment 3 Mark Chappell 2015-02-03 15:17:09 UTC
Interesting, it's consistently doing this for me...

What I did just notice is the following events:

	
2015-Jan-27, 17:46
State was set to Up for host h02.rhev.qa.int.phx1.redhat.com.
13
h02.rhev.qa.int.phx1.redhat.com
UCS1
oVirt

2015-Jan-27, 17:45
Failed to refresh the capabilities of host h02.rhev.qa.int.phx1.redhat.com.
607
mchappel
h02.rhev.qa.int.phx1.redhat.com
UCS1
1b564869
oVirt

Could it be something in the "failure" path that would trigger the host to come back up?

Comment 5 Eli Mesika 2015-02-03 15:28:55 UTC
(In reply to Mark Chappell from comment #3)

> Could it be something in the "failure" path that would trigger the host to
> come back up?

Seems so, will check... 
Thanks for the additional information

Comment 6 Eli Mesika 2015-02-04 14:53:53 UTC
Occurs probably only if the "refresh Capabilities" fails on a host with power management configured 
I had tested "failure" path for regular host with no PM , host remained in Maintenance 

please attach full engine.log and the vdsm.log of the host that is serving as a proxy for the fencing operation

Comment 12 Petr Matyáš 2016-01-15 14:45:05 UTC
Verified on 3.6.2-9

Comment 14 errata-xmlrpc 2016-03-09 20:55:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.