Bug 118682 - up2date -u is disastrous if autofs is upgraded while amd is running
up2date -u is disastrous if autofs is upgraded while amd is running
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-03-18 16:04 EST by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 16:46:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-03-18 16:04:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
When rpm attempts to install the /net directory while amd controls
/net, rpm fails, leaving the database with a partial transaction
completed: packages that were yet to be installed in the same
transaction are gone, and packages that were already installed have
incorrect database entries for config files, so they generate a lot of
rpmnew/rpmorig in case you reinstall them.

Version-Release number of selected component (if applicable):
autofs-4.1.0-8

How reproducible:
Always

Steps to Reproduce:
1.service amd start
2.up2date -u autofs

Actual Results:  There was a fatal RPM install error. The message was:
There was a rpm unpack error installing the package: autofs-4.1.0-8


Expected Results:  It should ideally install flawlessly, without
having to stop amd, but if stopping amd is the only way to avoid the
error, I guess we can live with it.

Additional info:
Comment 1 Nalin Dahyabhai 2004-03-30 19:20:16 EST
Bill, should filesystem create /net?
Comment 2 Nalin Dahyabhai 2004-03-30 19:21:18 EST
Details: prior to autofs 4.x, no package owned /net, so RPM attempts
to create the directory when autofs is installed.  If am-utils is
running, this fails.
Comment 3 Jeffrey Moyer 2004-03-30 20:06:04 EST
Bill, Nalin and I discussed this quite a bit.  Having filesystem own
this directory would solve many headaches.
Comment 4 Bill Nottingham 2004-03-31 00:33:11 EST
Does autofs use /net now?
Comment 5 Alexandre Oliva 2004-03-31 08:16:02 EST
Yup.  And it even works.  And better than amd when referencing
/net/`uname -r`/, since it uses bind mounts instead of NFS over loopback.
Comment 6 Jeffrey Moyer 2004-08-30 11:10:15 EDT
The autofs package no longer owns /net.  This should fix the problems
described here.
Comment 7 Alexandre Oliva 2004-09-04 15:02:16 EDT
A recent rawhide update has shown that upgrading autofs was no
problem, but I no longer use amd, so I can't quite tell whether it's
actually fixed.  I'll take your word for it :-)  Thanks, feel free to
close as far as I'm concerned.

Note You need to log in before you can comment on or make changes to this bug.