Bug 1186920 - publish_repo failures that do not raise an exception are marked as successful
Summary: publish_repo failures that do not raise an exception are marked as successful
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: API/integration
Version: 2.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
: 1193131 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-28 21:17 UTC by Barnaby Court
Modified: 2015-02-28 23:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 23:22:16 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 682 0 None None None Never

Description Barnaby Court 2015-01-28 21:17:56 UTC
Description of problem:

When a distributor has it's publish_repo method called and the publish report return indicates a failure the task is marked as completing successfully. If the publish_repo method raises an exception the task is marked properly as failed.

Comment 1 Dennis Kliban 2015-02-16 17:43:14 UTC
*** Bug 1193131 has been marked as a duplicate of this bug. ***

Comment 2 Brian Bouterse 2015-02-28 23:22:16 UTC
Moved to https://pulp.plan.io/issues/682


Note You need to log in before you can comment on or make changes to this bug.