Bug 118696 - more elaborate quotactl(2) deparser
more elaborate quotactl(2) deparser
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 18:38 EST by Dmitry V. Levin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.5.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 22:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace-4.5.2-alt-quotacmds-fix.patch (1.10 KB, patch)
2004-03-18 18:39 EST, Dmitry V. Levin
no flags Details | Diff
strace-4.5.6-alt-quotacmds-fix.patch (1.10 KB, patch)
2004-08-31 09:45 EDT, Dmitry V. Levin
no flags Details | Diff
strace-4.5.12-alt-quotacmds-fix.patch (1.51 KB, patch)
2005-06-15 14:54 EDT, Dmitry V. Levin
no flags Details | Diff
strace-4.5.12-alt-quotactl.patch (24.45 KB, patch)
2005-06-18 10:18 EDT, Dmitry V. Levin
no flags Details | Diff
strace-4.5.13-alt-quotactl.patch (24.80 KB, patch)
2005-08-08 13:24 EDT, Dmitry V. Levin
no flags Details | Diff
strace-4.5.14-alt-quotactl.patch (25.02 KB, patch)
2006-01-17 18:16 EST, Dmitry V. Levin
no flags Details | Diff

  None (edit)
Description Dmitry V. Levin 2004-03-18 18:38:12 EST
Description of problem: 
Different versions of the quotactl(2) commands share common names, which is 
sometimes confising. 
 
Version-Release number of selected component (if applicable): 
strace-4.5.2 
 
How reproducible: 
On filesystems with different quota versions.
Comment 1 Dmitry V. Levin 2004-03-18 18:39:11 EST
Created attachment 98669 [details]
strace-4.5.2-alt-quotacmds-fix.patch

Proposed patch.
Comment 2 Roland McGrath 2004-04-13 22:23:15 EDT
I don't like creating new symbolic names that are not macro names used
in sources.  I'm not sure there is any real good solution for this,
but that is not it.
Comment 3 Dmitry V. Levin 2004-04-17 16:54:05 EDT
Btw, Q_V2_* macros are present but have different semantic, so using them in 
this context is not so good idea as I thought before. 
 
What do you think about e.g. "v2(Q_GETQUOTA)" notation? 
Comment 4 Ulrich Drepper 2004-08-07 13:52:57 EDT
The more appropriate change is to change the old format since in
modern kernels there are no names for those commands anymore.  Here
you could be inventive.  The old headers are dying or died.  Enabling
people to find the names strace prints in the current headers is more
important.

So, I suggest to introduce Q_V1_*.  I don't  like a v1(...) notation.
 The former has the advantage that if somebody really wants to write
old quota code they could use these macro names.
Comment 5 Roland McGrath 2004-08-31 03:03:09 EDT
Dmitry, can you submit a patch that renames the old constants to
Q_V1_* and uses unadorned Q_* for the current kernel (V2 I guess)
constants?
Comment 6 Dmitry V. Levin 2004-08-31 09:45:21 EDT
Created attachment 103290 [details]
strace-4.5.6-alt-quotacmds-fix.patch

This patch renames V1-style commands.
Btw, the V2-style Q_GETSTATS appears to be missing.
Comment 7 Dmitry V. Levin 2005-06-15 14:54:51 EDT
Created attachment 115497 [details]
strace-4.5.12-alt-quotacmds-fix.patch

Rediffed for new strace version.
Comment 8 Dmitry V. Levin 2005-06-15 15:06:29 EDT
Since both glibc's sys/quota.h and kernel's linux/quota.h are incomplete
from strace point of view, and sys/quota.h is also outdated,
strace cannot rely on these header files.

My opinion is that quotactl decoder needs to be rewritten
using own header files like quota-tools project does.

Is there any flaws in this approach?
Comment 9 Dmitry V. Levin 2005-06-18 10:18:08 EDT
Created attachment 115653 [details]
strace-4.5.12-alt-quotactl.patch

Proposed quotactl deparser replacement.
Comment 10 Dmitry V. Levin 2005-06-23 17:25:08 EDT
With recent change in glibc
(I mean http://sources.redhat.com/ml/glibc-cvs/2005-q2/msg00436.html)
sys/quota.h looks much better, but still not sufficient for strace.
Comment 11 Dmitry V. Levin 2005-08-08 13:24:42 EDT
Created attachment 117547 [details]
strace-4.5.13-alt-quotactl.patch

Rediffed for strace-4.5.13.
Comment 12 Dmitry V. Levin 2006-01-17 18:16:47 EST
Created attachment 123342 [details]
strace-4.5.14-alt-quotactl.patch

Rediffed for strace-4.5.14, added Q_XQUOTASYNC command support.
Comment 13 Dmitry V. Levin 2006-11-26 06:44:48 EST
Fixed upstream.
Comment 14 Roland McGrath 2007-01-16 22:05:51 EST
4.5.15 in rawhide and in updates for fc5 and fc6 fixes this.

Note You need to log in before you can comment on or make changes to this bug.