Bug 118699 - avc: denied while running startx
avc: denied while running startx
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-18 19:28 EST by Ben Levenson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 14:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2004-03-18 19:28:22 EST
Description of problem:

(enforcing on)

running startx as a standard user resulted in the following messages:

avc:  denied  { read } for  pid=30807 exe=/usr/X11R6/bin/XFree86
name=mounts dev= ino=4105 scontext=user_u:user_r:user_xserver_t
tcontext=system_u:object_r:proc_t tclass=lnk_file
                                                                     
                                       
avc:  denied  { search } for  pid=30807 exe=/usr/X11R6/bin/XFree86
name=console dev=hdb1 ino=1436203
scontext=user_u:user_r:user_xserver_t
tcontext=system_u:object_r:xdm_var_run_t tclass=dir
                                                                     
                                       
Fatal server error:
PAM authentication failed, cannot start X server.
        Perhaps you do not have console ownership?


Version-Release number of selected component (if applicable):
policy-1.9-3
Comment 1 Daniel Walsh 2004-03-25 00:11:36 EST
Latest policy should clean this up
policy-1.9-15
Comment 2 Daniel Walsh 2004-05-06 14:26:17 EDT
Closing bugs since I believe these have been fixed for a long time in policy

Note You need to log in before you can comment on or make changes to this bug.