Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1186997 - Introduction of hornetq-ra breaks the overlay installer
Introduction of hornetq-ra breaks the overlay installer
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Retired
Component: Deployment (Show other bugs)
3.6
Unspecified Unspecified
high Severity high
: ---
: 3.6
Assigned To: Carlos Munoz
Damian Jansen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-29 00:57 EST by Damian Jansen
Modified: 2015-03-19 03:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.6.0-snapshot
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-19 03:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2015-01-29 00:57:00 EST
Description of problem:
On start up -
org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found

Version-Release number of selected component (if applicable):
3.6-snapshot

How reproducible:
Easy always

Steps to Reproduce:
1. Build Zanata
2. cd zanata-overlay/ && ~/bin/gradle-2.2.1/bin/gradle -q
3. unzip jboss, cd into jboss dir, unzip zanata-overlay/target/zanata-version.war
4. run the install script in bin/zanatainstaller and finish
5. Run standalone.sh

Actual results:
jboss.ejb.default-resource-adapter-name-service not found

Expected results:
JBoss / Zanata runs

Additional info:
Related to hornetq-ra, requires the appropriate parts in standalone.xml
e.g. https://developer.jboss.org/message/725587

15:49:59,514 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC000001: Failed to start service jboss.deployment.unit."zanata.war".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."zanata.war".PARSE: JBAS018733: Failed to process phase PARSE of deployment "zanata.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:166) [jboss-as-server-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_75]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_75]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_75]
Caused by: org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found
	at org.jboss.msc.service.ServiceContainerImpl.getRequiredService(ServiceContainerImpl.java:625) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]
	at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.getDefaultResourceAdapterName(MessageDrivenComponentDescriptionFactory.java:278)
	at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processMessageBeans(MessageDrivenComponentDescriptionFactory.java:155)
	at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processAnnotations(MessageDrivenComponentDescriptionFactory.java:82)
	at org.jboss.as.ejb3.deployment.processors.AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.processAnnotations(AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.java:58)
	at org.jboss.as.ejb3.deployment.processors.AbstractDeploymentUnitProcessor.deploy(AbstractDeploymentUnitProcessor.java:81)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:159) [jboss-as-server-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
	... 5 more
Comment 1 Carlos Munoz 2015-01-30 00:48:58 EST
Added the missing JMS configuration to the overlay standalone.xml

See: https://github.com/zanata/zanata-server/pull/679
Comment 2 Damian Jansen 2015-02-03 23:23:05 EST
Verified merge (release) at 2c4f8ec240745b9ca7baac7b53168814e9e87046

Note You need to log in before you can comment on or make changes to this bug.