Bug 1187021 - Geo-replication not replicating ACLs to target
Summary: Geo-replication not replicating ACLs to target
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1063028
Blocks: 1035040
TreeView+ depends on / blocked
 
Reported: 2015-01-29 08:10 UTC by Aravinda VK
Modified: 2015-05-14 17:35 UTC (History)
12 users (show)

Fixed In Version: glusterfs-3.7dev-0.852.git3feaf16.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1063028
Environment:
Last Closed: 2015-05-14 17:26:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-01-29 08:11:59 UTC
REVIEW: http://review.gluster.org/9499 (geo-rep: Add support for xattrs and acls) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2015-01-29 08:15:44 UTC
REVIEW: http://review.gluster.org/9499 (geo-rep: [WIP] Add support for xattrs and acls) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Anand Avati 2015-03-26 06:20:05 UTC
REVIEW: http://review.gluster.org/10001 (geo-rep: Add support for acls) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 4 Anand Avati 2015-03-30 13:57:21 UTC
COMMIT: http://review.gluster.org/10001 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 624938999bf925af710e9f73c75040416f68b756
Author: Kotresh HR <khiremat@redhat.com>
Date:   Wed Mar 25 23:39:16 2015 +0530

    geo-rep: Add support for acls
    
    This patch adds support for ACLS. When it sees SETXATTR
    in Changelog, it adds the file to data queue. rsync/tar+ssh
    will take care of syncing ACLS. User set ACLS will be
    synced to Slave.
    
    This requires "system.posix_acl_access" to go through when
    client-pid is equal GF_CLIENT_PID_GSYNCD in fuse layer.
    
    New config interface is introduced, sync-acls
    Which can be set using geo-rep config(Default is True)
    
    gluster volume geo-replication <VOLUME> <SLAVEHOST>::<SLAVEVOL> \
                   config sync-acls false
    
    Change-Id: I7eb3523fa72b8fed830efc98138891244e830d65
    BUG: 1187021
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/10001
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Tested-by: Venky Shankar <vshankar@redhat.com>

Comment 5 Niels de Vos 2015-05-14 17:26:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:28:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:35:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.