Bug 1187057 - Python-urllib3 fails to install
Summary: Python-urllib3 fails to install
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-urllib3
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-29 09:27 UTC by bhavya
Modified: 2020-02-01 19:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-18 17:18:46 UTC


Attachments (Terms of Use)

Description bhavya 2015-01-29 09:27:32 UTC
Description of problem:
Python-urllib3 fails to install or update

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. sudo yum clean all
2. sudo yum install python-urllib3

Actual results:
sudo yum install python-urllib3
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * fedora: mirrors.ustc.edu.cn
 * openclient: ocfedora.hursley.ibm.com
 * rpmfusion-free: mirrors.ustc.edu.cn
 * rpmfusion-free-updates: mirrors.ustc.edu.cn
 * rpmfusion-nonfree: mirrors.ustc.edu.cn
 * rpmfusion-nonfree-updates: mirrors.ustc.edu.cn
 * updates: mirrors.ustc.edu.cn
Resolving Dependencies
--> Running transaction check
---> Package python-urllib3.noarch 0:1.10-2.fc21 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================================================================
 Package                                            Arch                                       Version                                         Repository                                   Size
=================================================================================================================================================================================================
Installing:
 python-urllib3                                     noarch                                     1.10-2.fc21                                     updates                                     110 k

Transaction Summary
=================================================================================================================================================================================================
Install  1 Package

Total download size: 110 k
Installed size: 383 k
Is this ok [y/d/N]: y
Downloading packages:
python-urllib3-1.10-2.fc21.noarch.rpm                                                                                                                                     | 110 kB  00:00:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : python-urllib3-1.10-2.fc21.noarch                                                                                                                                             1/1 
Error unpacking rpm package python-urllib3-1.10-2.fc21.noarch
error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/urllib3/packages/ssl_match_hostname: cpio: rename
  Verifying  : python-urllib3-1.10-2.fc21.noarch                                                                                                                                             1/1 

Failed:
  python-urllib3.noarch 0:1.10-2.fc21                                                                                                                                                            

Complete!


Expected results:
Package python-urllib3 installed

Additional info:

Comment 1 Ralph Bean 2015-01-29 13:45:31 UTC
I think this is the same issue as in https://bugzilla.redhat.com/show_bug.cgi?id=1187057

Can you try the instructions there and let us know if it fixes your problem?

Comment 2 Ralph Bean 2015-02-18 17:18:46 UTC
Yeah, this is not a bug.  You 'sudo pip install'd urllib3 at one point and that is conflicting with rpm.

Please 'sudo pip uninstall urllib3' and then try yum installing again after that.

Comment 3 mbw 2019-09-12 05:53:41 UTC
This fixed my issue as well. I wanted to thank you for posting this as it would have taken us much longer to isolate the issue. Fantastic work.

Comment 4 Michael Watters 2019-09-27 14:18:00 UTC
Just ran into this as well.  It would be nice if the package could be updated to detect if urllib3 has been installed through pip and then show an error message with instructions on what to do.  I also disagree that this is not a bug, update failures are causing application failures which leads to down time.

Comment 5 I.Cekusins 2019-11-06 06:35:03 UTC
(In reply to Ralph Bean from comment #2)
> Yeah, this is not a bug.  You 'sudo pip install'd urllib3 at one point and
> that is conflicting with rpm.
> 
> Please 'sudo pip uninstall urllib3' and then try yum installing again after
> that.


Thank you very much Ralph!

Failure to upgrade urllib3 bugged me for a while. Now it is solved thanks to your post.

Comment 6 tech2blog 2020-02-01 19:31:36 UTC
My issue is also resolved after running > `sudo pip uninstall urllib3`.

Thanks for the help.


Note You need to log in before you can comment on or make changes to this bug.