Bug 118717 - Nautilus crashes instantly
Nautilus crashes instantly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-03-19 09:10 EST by Timo Kujala
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 10:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timo Kujala 2004-03-19 09:10:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
Instant crash when starting Nautilus.

0x0000002a9924cac5 in free () from /lib64/tls/libc.so.6
(gdb) bt
#0  0x0000002a9924cac5 in free () from /lib64/tls/libc.so.6
#1  0x0000002a98b6542f in g_free () from /usr/lib64/libglib-2.0.so.0
#2  0x0000002a984be2ba in ORBit_free_T (mem=0x500000000) at
allocators.c:187
#3  0x0000002a984be15a in ORBit_freekids_via_TypeCode_T (mem=0x7e57f0,
    tc=0x5a9560) at allocators.c:88
#4  0x0000002a984be126 in ORBit_freekids_via_TypeCode_T (mem=0x7e57f0,
    tc=0x2a98370e40) at allocators.c:65
#5  0x0000002a984be297 in ORBit_free_T (mem=0x500000000) at
allocators.c:197
#6  0x0000002a984be0b5 in ORBit_freekids_via_TypeCode_T (mem=0x7e5480,
    tc=0x2a98370ec0) at allocators.c:96
#7  0x0000002a984be297 in ORBit_free_T (mem=0x500000000) at
allocators.c:197
#8  0x0000002a984be2fd in ORBit_free (mem=0x7e5480) at allocators.c:213
#9  0x0000002a984be1f9 in CORBA_free (mem=0x500000000) at allocators.c:138
#10 0x0000002a982511b4 in read_drives_from_daemon (
    volume_monitor_client=0x7e5d80) at
gnome-vfs-volume-monitor-client.c:135
#11 0x0000002a98251319 in gnome_vfs_volume_monitor_client_init (
    volume_monitor_client=0x7e5410) at
gnome-vfs-volume-monitor-client.c:182
#12 0x0000002a98614dc4 in g_type_create_instance ()
   from /usr/lib64/libgobject-2.0.so.0
#13 0x0000002a98601a89 in g_object_new_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#14 0x0000002a98601242 in g_object_newv () from
/usr/lib64/libgobject-2.0.so.0
#15 0x0000002a98601a63 in g_object_new_valist ()
#16 0x0000002a98600fb7 in g_object_new () from
/usr/lib64/libgobject-2.0.so.0
#17 0x0000002a982532b0 in _gnome_vfs_get_volume_monitor_internal
(create=1)
    at gnome-vfs-volume-monitor.c:224
#18 0x0000002a982532ee in gnome_vfs_get_volume_monitor ()
    at gnome-vfs-volume-monitor.c:238
#19 0x0000000000429c12 in nautilus_application_instance_init (
    application=0x7dd960) at nautilus-application.c:182
#20 0x0000002a98614dc4 in g_type_create_instance ()
   from /usr/lib64/libgobject-2.0.so.0
#21 0x0000002a98601a89 in g_object_new_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#22 0x0000002a97f8ebdf in bonobo_object_query_local_interface ()
   from /usr/lib64/libbonobo-2.so.0
#23 0x0000002a98601242 in g_object_newv () from
/usr/lib64/libgobject-2.0.so.0
#24 0x0000002a98601a63 in g_object_new_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#25 0x0000002a98600fb7 in g_object_new () from
/usr/lib64/libgobject-2.0.so.0
#26 0x0000000000429cd2 in nautilus_application_new ()
    at nautilus-application.c:201
#27 0x00000000004350de in main (argc=1, argv=0x7fbffff9e8)
    at nautilus-main.c:319

Looks like the mem-variable gets trashed somewhere in ORBit_free_t ? 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start nautilus
2.
3.
    

Actual Results:  Crash.

Expected Results:  No crash.

Additional info:

Installed components:
nautilus-2.5.91-2
ORBit2-2.10.0-2
gnome-vfs2-2.5.91-2
glib2-2.4.0-1
Comment 1 Jeremy Katz 2004-05-06 23:55:41 EDT
Do you see this with what's in test3?
Comment 2 Alexander Larsson 2004-08-26 04:44:45 EDT
I believe this is fixed in later ORBit2 releases.
Comment 3 Alexander Larsson 2004-10-14 10:27:22 EDT
I'm pretty sure. Closing.

Note You need to log in before you can comment on or make changes to this bug.