Bug 118726 - Redhat Rel 9 wouldn't recognize Lucent WinModem Fedora Core 1 doesn't either
Redhat Rel 9 wouldn't recognize Lucent WinModem Fedora Core 1 doesn't either
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 11:22 EST by Carl H. Schmidt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-01 16:34:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl H. Schmidt 2004-03-19 11:22:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031211 Debian/1.5-2.0.0.lindows0.0.43.45+0

Description of problem:
As in summary, Redhat Rel 9 said no modem with Lucent Win V.92 on Port
3.  So I sent for Fedora Core 1.  Just installed on another system
still no modem.  How do I get the driver?  Searched Bugzilla, have a
very old entry about a laptop with a WinModem, answer was tough luck.
 Can't be true today.  I have Lindows (Switched HDAs) on the same
system, it has no problem with the modem.  Any help.  I went to Linux
because of frequent crashes with Microsoft. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 1
2. or try to configure a Win Modem
3.
    

Additional info:
Comment 1 Ed Bailey 2004-04-01 16:34:42 EST
The situation with respect to software modems (aka "winmodems") is a
difficult one, unfortunately.

Many of the winmodem chip manufacturers view their chips' interfaces
as being proprietary, making an open source driver that supports those
chips difficult (or impossible) to develop.  Of those manufacturers
that take this stance, some provide closed-source "binary only"
drivers.  Some do not.

The position of the Fedora Project (and its main sponsor, Red Hat) is
that closed-source software will not be included in our distributions.
  The reasons for this range from financial (with no direct sales of
Fedora Core, there's no revenue stream to support the necessary
finances to include such drivers) to ideological (we strongly feel
that the open source approach is best, and hope that manufacturers see
the growing Linux market as an incentive to open source their
drivers).  Other distributions may not share these same values, and/or
may be in a position to handle the financial aspects of proprietary
driver inclusion -- Lindows may be such a distribution (although I
have no direct experience with them, so I cannot say for sure).

We understand the difficulties this can cause -- I myself have a
laptop with an unsupported winmodem chip in it, and have a PC Card
modem to use in its place.

That said, there *are* resources available that might be of help to
you in getting your winmodem to work.  The first one that comes to
mind is www.linmodems.org -- based on the resources there, you should
be able to determine the status of support for your winmodem's
hardware.  I will note, however, that if you are fairly new to Linux,
you may find the steps necessary to get your winmodem operating daunting.

I wish you the best of luck, and hope that you find a
hardware/software solution that works for you, whether it includes
Fedora Core or not.

Note You need to log in before you can comment on or make changes to this bug.