Bug 1187260 - Config Groups not carried over when cloning a Host Group
Summary: Config Groups not carried over when cloning a Host Group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Host Group
Version: 6.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks: 1139277
TreeView+ depends on / blocked
 
Reported: 2015-01-29 16:23 UTC by David Juran
Modified: 2019-09-25 21:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:47:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 9274 None None None 2016-04-22 15:10:08 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description David Juran 2015-01-29 16:23:15 UTC
Description of problem:
When cloning a Host Group, Config Groups are not carried over to the clone

Version-Release number of selected component (if applicable):
satellite-6.0.6


Steps to Reproduce:
1. Create Host Group with a Config Grou
2. Clone the Host Group
3. Do note that the clone does not have any Config Groups assigned.

Comment 1 RHEL Program Management 2015-01-29 16:25:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 David Juran 2015-01-29 16:33:45 UTC
Possibly as a consequence of this, any Smart Class Parameters set on the original Host Group are also lost in the clone.

Comment 4 Bryan Kearney 2015-02-06 21:42:31 UTC
Created redmine issue http://projects.theforeman.org/issues/9274 from this bug

Comment 5 Bryan Kearney 2015-02-11 13:04:53 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9274 has been closed
-------------
Tom Caspy
Applied in changeset commit:6a07eb8155e82dcd7b22b2b41e05cb2233e8f52a.

Comment 6 Bryan Kearney 2015-02-18 22:26:43 UTC
Upstream bug assigned to tcaspy@redhat.com

Comment 7 Tazim Kolhar 2015-11-20 18:08:48 UTC
VERIFIED:
 rpm -qa  | grep foreman
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-pem600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-debug-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-proxy-1.11.0-0.develop.201511111339git7cbe47a.el7.noarch
foreman-compute-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201511111740gitb2a959e.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
1. Create Host Group with a Config Grou
2. Clone the Host Group
3. The clone does not have any Config Groups assigned.

Comment 12 errata-xmlrpc 2016-07-27 08:47:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.