Bug 1187317 - Deleting hosts from the "All Hosts" listing leaves them as Content Hosts.
Summary: Deleting hosts from the "All Hosts" listing leaves them as Content Hosts.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-29 18:36 UTC by Joe Giordano
Modified: 2019-10-10 09:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:13:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Joe Giordano 2015-01-29 18:36:05 UTC
Description of problem:
Creating a new host and then deleting the hosts leaves their entry in the content host section and the user has to do an unregister to fully remove the entry. 

Version-Release number of selected component (if applicable):
6.0.7

How reproducible:
Always

Steps to Reproduce:
1. Create a new host.
2. Validate it was provisioned and registered successfully 
3.Click hosts > Content Hosts and validate the entry exists.
4. Go back to Hosts > All Hosts
5. Poweroff (if it is virtual) and delete the host.
6. Go back to Hosts > Content Hosts and validate the existance of the host. 

Actual results:
Host is still listed in the content host listing even after deleting.

Expected results:
Either the host is automatically removed or the user is asked whether they would like to automatically remove the host fromt he Content Hosts/ 

Additional info:

Comment 1 RHEL Product and Program Management 2015-01-29 18:54:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Joe Giordano 2015-01-29 19:23:50 UTC
This seems to happen specifically when using RHEV/Ovirt images to provision, then powering them off and deleting them.

Comment 4 Tom McKay 2015-02-13 21:08:56 UTC
Created redmine issue http://projects.theforeman.org/issues/9384 from this bug

Comment 5 Joe Giordano 2015-02-23 14:35:14 UTC
As an additional thought, this issue has the potential to consume subscriptions if users delete from the all hosts and leave the content hosts. Users may have issues provisioning and troubleshooting that as opposed to looking if they are maxed out on subs.

Comment 6 Bryan Kearney 2015-08-25 18:33:14 UTC
Upstream bug component is Content Management

Comment 8 Komal 2015-09-10 08:34:07 UTC
Hello,

After upgrade to satellite 6.1 customer is no longer facing the issue and seems to be fixed. 

Regards,
Komal

Comment 9 Brad Buckingham 2016-03-07 15:51:19 UTC
Satellite 6.2 includes a feature referred to as 'host unification'.  With that feature, this behavior should no longer occur. 

Moving bug to ON_QA for verification.

Comment 11 sthirugn@redhat.com 2016-04-04 18:11:51 UTC
Verified in Satellite 6.2-beta-snap-6.1

I did the exact same steps as mentioned in the bug description.  After deleting the host, the host is gone form both 'All Hosts' page and 'Content Hosts' page.

Comment 13 errata-xmlrpc 2016-07-27 09:13:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.