Bug 1187470 - katello-installer failed with /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[FQDN]: Could not evaluate: Could not load data from https://FQDN
Summary: katello-installer failed with /Stage[main]/Foreman_proxy::Register/Foreman_sm...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-30 06:31 UTC by Sachin Ghai
Modified: 2019-09-26 17:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:47:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
installer logs (991.65 KB, text/plain)
2015-01-30 06:31 UTC, Sachin Ghai
no flags Details
foreman-debug attached (346.41 KB, application/x-xz)
2015-01-30 06:55 UTC, Tazim Kolhar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2015-01-30 06:31:18 UTC
Created attachment 985854 [details]
installer logs

Description of problem:
Recent katello-installer on rhel7/66 in nightly(katello+foreman) failed with error:

[ INFO 2015-01-30 01:23:43 verbose] Executing hooks in group post
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log
[ INFO 2015-01-30 01:23:43 verbose] All hooks in group post finished
[ERROR 2015-01-30 01:23:43 verbose] Repeating errors encountered during run:
[ERROR 2015-01-30 01:23:43 verbose]  /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
[ERROR 2015-01-30 01:23:43 verbose]  /Stage[main]/Certs::Foreman/Exec[foreman_certs_config]/returns: change from notrun to 0 failed: /usr/share/foreman/script/foreman-config      -k ssl_ca_file -v '/etc/foreman/proxy_ca.pem'      -k ssl_certificate -v '/etc/foreman/client_cert.pem'      -k ssl_priv_key -v '/etc/foreman/client_key.pem' returned 1 instead of one of [0]
[ERROR 2015-01-30 01:23:43 verbose]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[qe-foreman-rhel7.usersys.redhat.com]: Could not evaluate: Could not load data from https://qe-foreman-rhel7.usersys.redhat.com
[ERROR 2015-01-30 01:23:43 verbose]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[qe-foreman-rhel7.usersys.redhat.com]: Failed to call refresh: Could not load data from https://qe-foreman-rhel7.usersys.redhat.com
[ERROR 2015-01-30 01:23:43 verbose]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[qe-foreman-rhel7.usersys.redhat.com]: Could not load data from https://qe-foreman-rhel7.usersys.redhat.com
[

Version-Release number of selected component (if applicable):
* candlepin-0.9.38-1.el7.noarch
* candlepin-common-1.0.18-1.el7.noarch
* candlepin-selinux-0.9.38-1.el7.noarch
* candlepin-tomcat-0.9.38-1.el7.noarch
* elasticsearch-0.90.10-7.el7.noarch
* foreman-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-compute-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-gce-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-libvirt-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-ovirt-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-postgresql-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-proxy-1.8.0-0.develop.201501280951gite1bc928.el7.noarch
* foreman-release-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el7.noarch
* foreman-vmware-1.8.0-0.develop.201501290916git1f0e9bd.el7.noarch
* katello-2.1.0-1.201411061509gitb0b8f43.el7.noarch
* katello-certs-tools-2.0.1-1.el7.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.2.0-1.201501272021gitf707d62.el7.noarch
* katello-installer-base-2.2.0-1.201501272021gitf707d62.el7.noarch
* katello-repos-2.1.1-1.el7.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-3.el7.x86_64
* pulp-docker-plugins-0.2.1-0.2.beta.el7.noarch
* pulp-katello-0.3-3.el7.noarch
* pulp-nodes-common-2.5.1-1.el7.noarch
* pulp-nodes-parent-2.5.1-1.el7.noarch
* pulp-puppet-plugins-2.5.1-1.el7.noarch
* pulp-puppet-tools-2.5.1-1.el7.noarch
* pulp-rpm-plugins-2.5.1-1.el7.noarch
* pulp-selinux-2.5.1-1.el7.noarch
* pulp-server-2.5.1-1.el7.noarch
* python-ldap-2.4.6-6.el7.x86_64
* ruby193-rubygem-ldap_fluff-0.3.3-1.el7.noarch
* ruby193-rubygem-net-ldap-0.10.0-1.el7.noarch
* ruby193-rubygem-runcible-1.3.0-1.el7.noarch
* rubygem-hammer_cli-0.1.4-1.201501260908gitf44b8c5.el7.noarch
* rubygem-hammer_cli_foreman-0.1.4-1.201501221305git706b057.el7.noarch
* rubygem-hammer_cli_foreman_bootdisk-0.1.2-1.el7.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410git163c264.git.0.988ca80.el7.noarch
* rubygem-hammer_cli_import-0.10.4-1.el7.noarch
* rubygem-hammer_cli_katello-0.0.7-1.201501281312git793226f.git.0.7c94372.el7.noarch


How reproducible:
recent nightly

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Installer should succeed

Additional info:

Comment 1 Sachin Ghai 2015-01-30 06:37:13 UTC
redmine issue: http://projects.theforeman.org/issues/9172

Comment 3 Tazim Kolhar 2015-01-30 06:51:52 UTC
Failed for a system tried manually :

[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ INFO 2015-01-30 01:45:40 verbose] All hooks in group post finished
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose] Repeating errors encountered during run:
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: error reading information on service postgresql: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Postgresql::Server::Service/Service[postgresqld]/ensure: change from stopped to running failed: Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: error reading information on service postgresql: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  Could not enable mongod: Execution of '/sbin/chkconfig --add mongod' returned 1: error reading information on service mongod: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Mongodb::Server::Service/Service[mongodb]/ensure: change from stopped to running failed: Could not enable mongod: Execution of '/sbin/chkconfig --add mongod' returned 1: error reading information on service mongod: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: /usr/sbin/foreman-rake db:migrate returned 1 instead of one of [0]
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  Could not enable puppet: Execution of '/sbin/chkconfig --add puppet' returned 1: error reading information on service puppet: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Puppet::Agent::Service/Service[puppet]/ensure: change from stopped to running failed: Could not enable puppet: Execution of '/sbin/chkconfig --add puppet' returned 1: error reading information on service puppet: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  Could not enable foreman-proxy: Execution of '/sbin/chkconfig --add foreman-proxy' returned 1: error reading information on service foreman-proxy: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman_proxy::Service/Service[foreman-proxy]/ensure: change from stopped to running failed: Could not enable foreman-proxy: Execution of '/sbin/chkconfig --add foreman-proxy' returned 1: error reading information on service foreman-proxy: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  Could not enable qpidd: Execution of '/sbin/chkconfig --add qpidd' returned 1: error reading information on service qpidd: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Qpid::Service/Service[qpidd]/ensure: change from stopped to running failed: Could not enable qpidd: Execution of '/sbin/chkconfig --add qpidd' returned 1: error reading information on service qpidd: No such file or directory
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: Failed to call refresh: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman::Database/Foreman::Rake[apipie:cache]/Exec[foreman-rake-apipie:cache]: /usr/sbin/foreman-rake apipie:cache returned 1 instead of one of [0]
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com]: Failed to call refresh: Could not load data from https://hp-dl380pgen8-02-vm-7.lab.bos.redhat.com
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: [ERROR 2015-01-30 01:45:40 verbose]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com]: Could not load data from https://hp-dl380pgen8-02-vm-7.lab.bos.redhat.com
[hp-dl380pgen8-02-vm-7.lab.bos.redhat.com] out: 


Fatal error: run() received nonzero return code 6 while executing!

Requested: katello-installer -v -d --foreman-admin-password="changeme"
Executed: /bin/bash -l -c "katello-installer -v -d --foreman-admin-password=\"changeme\""

Aborting.

Comment 4 Tazim Kolhar 2015-01-30 06:55:04 UTC
Created attachment 985855 [details]
foreman-debug attached

Comment 6 Sachin Ghai 2015-01-30 06:59:42 UTC
Just to clarify, I downgraded the puppet to 3.7.3 to get rid of chkconfig issues as stated in comment 3, but still getting errors as mentioned in original description.

Comment 7 Sachin Ghai 2015-02-02 07:24:36 UTC
Still an issue in recent nightly though upstream issue has been closed.

Comment 8 Eric Helms 2015-02-08 16:18:41 UTC
Can you re-test with latest nightly and le tme know if you are still seeing this issue?

Comment 9 Dmitry S. Makovey 2015-02-12 20:22:18 UTC
Facing the same issue:

[root@foo ~]# katello-installer --foreman-admin-username admin --foreman-admin-password admin123
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[cs0-sw.cs.athabascau.ca]: Could not evaluate: Could not load data from https://foo.athabascau.ca
Installing             Done                                               [100%] [..........................................................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/katello-installer/katello-installer.log


# rpm -q katello
katello-1.5.0-30.el6sat.noarch
# yum repolist
Loaded plugins: product-id, security, subscription-manager
repo id                                         repo name                                                                               status
rhel-6-server-rpms                              Red Hat Enterprise Linux 6 Server (RPMs)                                                14,590
rhel-6-server-satellite-6.0-rpms                Red Hat Satellite 6.0 (for RHEL 6 Server) (RPMs)                                           424
rhel-server-rhscl-6-rpms                        Red Hat Software Collections RPMs for Red Hat Enterprise Linux 6 Server                  2,552
repolist: 17,566

Comment 10 Dmitry S. Makovey 2015-02-12 20:24:40 UTC
(In reply to Dmitry S. Makovey from comment #9)

foo.athabascau.ca and cs0-sw.cs.athabascau.ca are the same... sorry for the mess-up

Comment 11 Dmitry S. Makovey 2015-02-12 22:55:28 UTC
# katelloo-installer --reset 

resolved the issue for me

Comment 14 Sachin Ghai 2016-04-07 11:50:36 UTC
Verified with sat6.2 beta snap6.2

Now installer name changed from katello-installer to foreman-installer and it was completed successfully with sat6.2 beta snap6.2


~]# foreman-installer --scenario katello --foreman-admin-password changeme
Installing             Done                                               [100%] [..................................................................]
  Success!

Comment 16 errata-xmlrpc 2016-07-27 08:47:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.