Bug 1187488 - Pacemaker resource defaults should show up in 'pcs config' output
Summary: Pacemaker resource defaults should show up in 'pcs config' output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On: 1176687
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-30 08:22 UTC by Tomas Jelinek
Modified: 2015-07-22 06:16 UTC (History)
5 users (show)

Fixed In Version: pcs-0.9.139-1.el6
Doc Type: Bug Fix
Doc Text:
* The "pcs status --full" command did not output the node attributes and migration summary. Similarly, the "pcs config" command did not display the resource and operation defaults. Both commands have been modified to display this information. (BZ#1184922, BZ#1187488)
Clone Of: 1176687
Environment:
Last Closed: 2015-07-22 06:16:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1446 normal SHIPPED_LIVE pcs bug fix and enhancement update 2015-07-20 18:43:57 UTC

Description Tomas Jelinek 2015-01-30 08:22:40 UTC
+++ This bug was initially created as a clone of Bug #1176687 +++

Description of problem:
pacemaker resource defaults are not shown in 'pcs config' output

Version-Release number of selected component (if applicable):
pcs-0.9.137-5.el7.x86_64

How reproducible:


Steps to Reproduce:
[root@rh7-1 ~]# pcs resource defaults 
No defaults set
[root@rh7-1 ~]# pcs resource defaults resource-stickiness=500
[root@rh7-1 ~]# pcs resource defaults     
resource-stickiness: 500
[root@rh7-1 ~]# pcs config | grep resource-stickiness
[root@rh7-1 ~]# 


pcs config output should show resource defaults

Comment 1 Tomas Jelinek 2015-01-30 09:48:07 UTC
Upstream patch:
https://github.com/feist/pcs/commit/ac492e40ef855b0a013e21926314bde5e2793aeb

Test:

[root@rh66-node1:~]# pcs resource defaults
No defaults set
[root@rh66-node1:~]# pcs resource defaults resource-stickines=500
[root@rh66-node1:~]# pcs resource defaults
resource-stickines: 500
[root@rh66-node1:~]# pcs config | grep resource-stickines
 resource-stickines: 500

[root@rh66-node1:~]# pcs resource op defaults
No defaults set
[root@rh66-node1:~]# pcs resource op defaults timeout=30
[root@rh66-node1:~]# pcs resource op defaults
timeout: 30
[root@rh66-node1:~]# pcs config | grep 'timeout:'
 timeout: 30

Comment 2 Tomas Jelinek 2015-02-18 10:24:23 UTC
Before Fix:
[root@rh66-node1 ~]# rpm -q pcs
pcs-0.9.138-1.el6.x86_64
[root@rh66-node1:~]# pcs config
Cluster Name: cluster66
Corosync Nodes:
 rh66-node1 rh66-node2 
Pacemaker Nodes:
 rh66-node1 rh66-node2 

Resources: 

Stonith Devices: 
Fencing Levels: 

Location Constraints:
Ordering Constraints:
Colocation Constraints:

Cluster Properties:
 cluster-infrastructure: cman
 dc-version: 1.1.11-97629de
 last-lrm-refresh: 1417169339
[root@rh66-node1:~]# pcs resource defaults resource-stickines=500
[root@rh66-node1:~]# pcs resource op defaults timeout=30
[root@rh66-node1:~]# pcs config
Cluster Name: cluster66
Corosync Nodes:
 rh66-node1 rh66-node2 
Pacemaker Nodes:
 rh66-node1 rh66-node2 

Resources: 

Stonith Devices: 
Fencing Levels: 

Location Constraints:
Ordering Constraints:
Colocation Constraints:

Cluster Properties:
 cluster-infrastructure: cman
 dc-version: 1.1.11-97629de
 last-lrm-refresh: 1417169339



After Fix:
[root@rh66-node1:~]# rpm -q pcs
pcs-0.9.139-1.el6.x86_64
[root@rh66-node1:~]# pcs config
Cluster Name: cluster66
{snip}
Colocation Constraints:

Resources Defaults:
 No defaults set
Operations Defaults:
 No defaults set

Cluster Properties:
 cluster-infrastructure: cman
 dc-version: 1.1.11-97629de
 last-lrm-refresh: 1417169339
[root@rh66-node1:~]# pcs resource defaults resource-stickines=500
[root@rh66-node1:~]# pcs resource op defaults timeout=30
[root@rh66-node1:~]# pcs config
Cluster Name: cluster66
{snip}
Colocation Constraints:

Resources Defaults:
 resource-stickines: 500
Operations Defaults:
 timeout: 30

Cluster Properties:
 cluster-infrastructure: cman
 dc-version: 1.1.11-97629de
 last-lrm-refresh: 1417169339
[root@rh66-node1:~]# pcs resource defaults resource-stickines=
[root@rh66-node1:~]# pcs resource op defaults timeout=
[root@rh66-node1:~]# pcs config
Cluster Name: cluster66
{snip}
Colocation Constraints:

Resources Defaults:
 No defaults set
Operations Defaults:
 No defaults set

Cluster Properties:
 cluster-infrastructure: cman
 dc-version: 1.1.11-97629de
 last-lrm-refresh: 1417169339

Comment 6 errata-xmlrpc 2015-07-22 06:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1446.html


Note You need to log in before you can comment on or make changes to this bug.