Bug 1187498 - It's not possible to install standalone JON server (without storage node) in HA
Summary: It's not possible to install standalone JON server (without storage node) in HA
Status: CLOSED DUPLICATE of bug 1180343
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: High Availability
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: John Mazzitelli
QA Contact: Filip Brychta
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-30 09:08 UTC by Filip Brychta
Modified: 2015-01-30 09:35 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2015-01-30 09:35:31 UTC


Attachments (Terms of Use)

Description Filip Brychta 2015-01-30 09:08:34 UTC
Description of problem:
It's not possible to add additional JON server without storage node to HA set up.

Version-Release number of selected component (if applicable):
Version :	
3.3.0.GA
Build Number :	
4f16df3:e347f77

How reproducible:
Always

Steps to Reproduce:
1. Install JON server + agent + SN on server1 with db configured to HA set up
2. Try to install additional JON server without storage node on server2 which should be part of this HA set up:
    a) unzip package
    b) configure rhq-server.properties
    c) ./rhqctl install --server


Actual results:
The installation is aborted:

03:41:57,370 WARN  [org.rhq.server.control.command.Start] It appears that the storage node is not installed. The --storage option will be ignored.
03:41:57,371 INFO  [org.rhq.server.control.command.Install] Pausing to ensure RHQ Storage is initialized prior to RHQ Server installation.
03:42:09,872 WARN  [org.rhq.server.control.command.Stop] It appears that the storage node is not installed. The --storage option will be ignored.

Expected results:
Installation works

Additional info:
This is regression, the same approach works on JON3.2.0.GA.
To reproduce, it's possible to skip step 1 and run just ./rhqctl install --server

Upgrade of this set up from JON 3.2.0.GA to JON 3.3 works: https://tcms.engineering.redhat.com/run/195543/
So this affect only clean installation of JON 3.3.0.GA

Comment 1 Filip Brychta 2015-01-30 09:35:31 UTC

*** This bug has been marked as a duplicate of bug 1180343 ***


Note You need to log in before you can comment on or make changes to this bug.