Bug 118771 - [firewire] kudzu 1.1.53-1 causes a kernel panic
Summary: [firewire] kudzu 1.1.53-1 causes a kernel panic
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-19 23:25 UTC by mark
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 00:32:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mark 2004-03-19 23:25:16 UTC
I get a kernel panic shortly after "Enabling swap space": 

call trace

<0212b1e3> run_timer_softirq+0xe0/0x32b
<02134c70> rcu_do_batch+0x26/0x2e
<02127435> _do_softirq+0x35/0x73
<0210c3c4> do_softirq+0x4b/0x4d
=================================================
<0210b7b7> do_IRQ+0x2f7/0x303

kernel/timer.c:295:spin_lock(kernel/timer.c:0230e3a0) already locked
by kernel/timer.c/392
Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing

a similar error message can be found in bug 118202 except for the call
trace which is different...

also, interestingly, similar to 118202, issuing the command
"/sbin/chkconfig kudzu off" to bash and then rebooting eliminates the
kernel panic.

i have an ATI radeon pci card and an adaptec 4300 fireconnect firewire
pci card. 

i can't get any of the 2.6.3 kernels or arjanv's 2.6.4 kernel to work
since updating several packages recently (without turning off kudzu).
i was forced to revert back to the 2.6.1-1.65 kernel which luckily for
me works fine even with kudzu on.

btw, unrelated i think, but when i rpm install the 2.6.4 kernel i get
the following error messages:

WARNING: /lib/modules/2.6.4-1.275/unsupported/drivers/video/sstfb.ko
needs unknown symbol fb_find_mode
WARNING:
/lib/modules/2.6.4-1.275/unsupported/drivers/video/aty/radeonfb.ko
needs unknown symbol fb_find_mode
WARNING:
/lib/modules/2.6.4-1.275/unsupported/drivers/video/aty/aty128fb.ko
needs unknown symbol fb_find_mode
WARNING: /lib/modules/2.6.4-1.275/kernel/drivers/video/tridentfb.ko
needs unknown symbol fb_find_mode

Comment 1 Bill Nottingham 2004-03-20 03:14:23 UTC
You have a firewire controller, by any chance?

Comment 2 mark 2004-03-20 03:20:24 UTC
yeah, i have a adaptec 4300 fireconnect firewire pci card...

Comment 3 Darin May 2004-03-21 20:13:13 UTC
I get a lockup with kernel 2.6.3-110smp, but not with *-253smp (I have
to run 110 for the nVidia driver)

Comment 4 mark 2004-03-23 16:03:12 UTC
it appears this is fixed in 2.6.4-1.286...

Comment 5 Sahil Verma 2004-03-26 18:35:28 UTC
Please close this bug.


Note You need to log in before you can comment on or make changes to this bug.