Bug 1187741 - dnf should state if packages explicitly requested for update aren't installed
Summary: dnf should state if packages explicitly requested for update aren't installed
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 21
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-30 18:54 UTC by bryant
Modified: 2015-06-24 16:58 UTC (History)
7 users (show)

Fixed In Version: dnf-1.0.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-21 00:16:31 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bryant 2015-01-30 18:54:25 UTC
Description of problem:
I was trying to update my version of the `zip` software from the updates-testing repo to test the new update and I kept getting a "Nothing to do" message from dnf. Turns out the package I was trying to update wasn't even installed. dnf should either prompt the user to install these packages or at least notify the user that the package wasn't installed so updating won't occur.


Version-Release number of selected component (if applicable):
dnf-0:0.6.3-2.fc21

How reproducible:
Always


Steps to Reproduce:
1. run `sudo dnf update PACKAGE_THATS_NOT_INSTALLED -y`

Actual results:
"Dependencies resolved.\nNothing to do." is output

Expected results:
A notice or warning that the package isn't installed so updating can't be done. It could even prompt the user to install the requested package in this case. Since this is an explicit request from the user, I don't see how that would be a bad thing.


Additional info:

Comment 1 Honza Silhan 2015-02-09 17:27:55 UTC
Thanks for the report. Fixed. PR: https://github.com/rpm-software-management/dnf/pull/220

Comment 2 bryant 2015-02-09 19:26:11 UTC
Excellent, looked at the PR and it looks good (I know Python but not familiar with DNF's internals).

Did you decide that adding a prompt to install the software that was requested isn't worth the code complexity? I think it'd be very nice from a UX perspective though I could see how it could be a lot of extra code.

Comment 3 Ben Boeckel 2015-02-23 17:00:50 UTC
See also Bug #1195106. I'd like more information than a confirmation of "nope, couldn't do it". I'd like to know *why*. Especially since it's being held back to a Fedora 20 version...

Comment 4 Fedora Update System 2015-06-12 09:05:49 UTC
dnf-1.0.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-1.0.1-2.fc22

Comment 5 Fedora Update System 2015-06-14 17:33:44 UTC
Package dnf-1.0.1-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-1.0.1-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10004/dnf-1.0.1-2.fc22
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-06-21 00:16:31 UTC
dnf-1.0.1-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 bryant 2015-06-24 16:58:32 UTC
Yep, this fixed it now. Thanks!


Note You need to log in before you can comment on or make changes to this bug.